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1 PREFACE 
 

This guide is intended for use by technically competent personnel when using the IT1000 ISDN unit to make tests on ISDN 
lines.   

Throughout this manual certain typographical conventions are used as follows: 

 

 

Text Type Meaning 

Text like this … is standard text 

Z This text and symbol … indicate points which are important for the correct operation of 
the unit. 

        This text and symbol … 
indicate points which if ignored may cause harm either to the unit 
or the safety of the user and MUST be followed. 

ü Tip Gives useful information and hints on using the device. 

Text like this … Indicates terminal input or output from the unit to a terminal 
device. 

File > Save An instruction to navigate using the menu system.  In this 
example to select the File Menu, then the Save submenu.  
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2 INTRODUCTION 
 

2.1 Description 

Thank you for purchasing the Black Box IT1000 Basic Rate ISDN Line Tester. 

The IT1000 is a pocket-sized unit, which despite its small size performs powerful tests to determine 
the integrity of Euro ISDN lines.   

It can be used as a self-contained device to perform fast integrity checks in the field using a single 
button to trigger voice, data and Packet Mode Bearer Service (X.31) tests. 

Connected to a PC or laptop to access the built in serial port, the IT1000 becomes a powerful test 
instrument complete with ISDN layer 1, 2 & 3 protocol analysis, event logger and much more. 

With the optional mains power supply (PSU1000), it can be deployed to remote sites and left in 
position reporting the status of ISDN services to a central control point.  In this mode, it is ideal for 
finding and eliminating intermittent problems without committing service personnel to long and 
expensive investigations. 

The tester can also be used as a fully functional ISDN Terminal Adaptor (with an additional option) 
capable of making V.120 and PPP calls when used with a laptop computer or PC enabling service 
personnel to make outgoing calls to connect to the Internet or a remote service centre for job 
allocation etc. 

2.2 Unpacking the tester. 

Open the box and carefully take out all of the items. These should include: 

§ IT1000 ISDN Tester 

§ 9V PP3 Battery 

§ 2 metre ISDN connection lead 

§ 2 metre serial cable with 9 pin adaptor 

§ Disk containing this manual and other test software 

If ordered as options, you may also have : 

§ Rechargeable NiMh battery & Charger 

§ Mains Power Supply 

§ Protective carry case 

§ Software to enable your tester to operate as an ISDN Terminal Adaptor 

Check each item to make sure there are no visible defects. If any item is missing or damaged please 
contact your supplier. You should also make a record of any damage that may have occurred during 
shipping and report it to the carrier. 
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2.3 Take a closer look. 

Now that you have the tester out of the box, take a closer look so that you are familiar with the 
various connectors and indicators. 

2.3.1 The front panel 

The front panel of the tester features 8 LED indicators that will illuminate steady or flashing when 
the unit is in use to indicate the status of various tests which the unit can perform. 

 

Figure 1. IT1000 front panel 

The indicator labelled Power will illuminate steady red when the unit is switched on by pressing 
AND HOLDING the red button marked ON (auto-off). 

Tests are selected by repeatedly pressing the green button marked MODE / RUN until the pattern of 
lights on the indicators matches the required test marked on the unit’s label.  Further details on this 
function can be found in Section 2.2. 

The indicator marked Line Active will illuminate when the tester has been correctly attached to an 
ISDN line and a physical (Layer 1) connection has been established between the tester and the local 
exchange. 

The next group of three indicators labelled Call Control L2, D-X.25 L2 and X.25 Call L3 reflect 
the status of the SAPI 0 and SAPI 16 traffic between the tester and the exchange and will illuminate 
as the tests progress to indicate that the tester has established a connection at this level. 

The B1 or B2 indicators will illuminate steady when the respective B-channel is active. If data is 
being transmitted or received over any of these channels the appropriate indicator will flash. These 
indicators together with the Pass / Fail indicator are also used to select the required test (see below).  
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The B1 indicator will also flash briefly when the unit is first powered up to indicate that the unit is 
performing a self-test. When it stops flashing the unit is ready to use. 

The Pass / Fail indicator illuminates after a test is performed to give the result of the test.  A green 
light together with a rising tone from the internal speaker indicates a successful test.  A red light 
together with a falling tone from the internal speaker indicates a test failure. 

You will notice that the LED indicators are also marked at the right hand side with a scale reading 
from 10 Volts to >70 Volts.  This scale is used in conjunction with the Line Voltage test to show the 
actual voltage on the line from the exchange. 

On the left side of the unit there are connectors for the ISDN line under test and for a laptop 
computer or PC to enable more sophisticated tests to be carried out together with a power input 
socket.  The use of these connectors is explained fully below. 

2.3.2 The rear panel 

The rear panel of the unit has a hatch for the main battery which can be opened by slight downward 
pressure where indicated and sliding the hatch upwards towards the top of the unit. 

There are no other user controls inside the unit and it should be noted that removal of the case screws 
will invalidate both the warranty and the safety approvals. 

2.3.3 The battery  

The IT1000 is battery powered to enable tests to be carried out in the field without the need for 
additional power supplies.   

A standard PP3 or MN1500 battery should be used.  We recommend that only good quality Alkaline 
or Lithium batteries should be used, such as Duracell™. 

The unit can be supplied as an option with a high power rechargeable Nickel Metal Hydride battery 
which will power the unit for between 6 and 10 hours depending on the tests performed.  The battery 
can be removed and recharged in the supplied charger about 1,000 times before a replacement is 
needed. 

 

 The supplied battery contains compounds that may be hazardous to the environment and therefore 
MUST be disposed of properly at the end of its life.
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To gain access to the battery, the battery compartment cover must be removed as shown above. 

 The unit can be powered by either the supplied Ni-Mh battery or by any other PP3 type battery.  However, 
we recommend that only good quality alkaline or lithium cells are used (Duracell MN1604B2 or equivalent 
of size IEC 6 F 22)  

Black Box do not recommend the use of rechargeable cells other than the ones supplied with the unit, doing 
so may result in erroneous test results and will invalidate the warranty. 

 

2.3.4 Recharging the battery 

The rechargeable battery can be recharged at any time as it does not suffer from ‘memory effect’ as 
is the case with some other batteries. 

To recharge the battery, remove it from the unit as described above and push the contact end into the 
slot in the charger ensuring that the polarity is correct.   

A complete charge cycle takes approximately 14 hours and charging will be indicated by the red 
LED on the charger, however, the battery may be partially charged and returned to the unit if a full 
charge cycle is not possible. 

Note that if the battery has been completely discharged or has been stored for several months, it may 
be necessary to complete several charging cycles before it returns to its full capacity. 

 Caution.  The supplied rechargeable battery and charger are designed for correct operation together.  
Charging the supplied battery in a different charger may be hazardous and is not recommended.  Under no 
circumstances should dry batteries such as alkaline cells be placed into the charger as there is a danger of 
explosion. 
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2.3.5 ISDN connector 

The connector labelled ISDN BRI is used to connect the tester to the ISDN network using the cable 
supplied. One end of the cable should be fitted into this connector (with the retaining clip at the 
bottom) before the other end is connected to the wall mounted ISDN outlet socket. 

 Be careful not to connect the ISDN line to the port marked DTE as high line voltages from the exchange 
may damage this port and will invalidate the warranty.  We recommend that you keep the supplied ISDN test 
cable permanently attached to the unit to prevent mistakes. 

2.3.6 Asynchronous serial port 

The connector marked DTE is designed to be used to attach a Personal Computer to the unit to 
enable access to the test programming menus and the extensive protocol analysis features of the unit.  
It can also be used to enable a PC to access external ISDN based services such as the Internet. 

A serial connection lead is supplied with the unit which terminates in a 9 way female ‘D’ type 
connector (25 Way connectors are available as an option). 

Communication with the unit is achieved either by using the supplied application software or when it 
is used as a Terminal Adaptor (Option Pack 2), it can be used with any normal communication 
package as if it were a standard Hayes® AT-type Modem 

It is also possible to connect to the unit using a standard terminal program such as HyperTerm™ 
which is supplied with the Windows Operating System.  

 In this case you will need to set your program to communicate as follows : 

 Speed  115 Kb/s   

  Data Bits  8 

 Parity  None 

 Stop Bits  1 

If you wish to use a lead other than the one supplied, it must be wired according to diagram given in 
the appendix.  
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3 USING THE IT1000  
 

In order to make best use of your tester it is important that you take the time to read this section of 
this guide carefully. It explains the basic operating modes of the IT1000 and will help in your 
understanding of how to configure the unit for different applications. 

3.1 Operation Modes 

The IT1000 can be used in two distinct modes : 

1) Stand Alone Mode.  As a stand alone tester requiring nothing else to perform a range of pre-
configured tests. 

2) Explorer Mode.  Together with a personal computer to perform more detailed investigations 
and / or to configure the test parameters to be used in stand alone mode. 

 

3.2 Stand Alone Mode 

3.2.1 Turning the unit on 

Press the button marked ON (auto-off) and hold it in for 2 seconds.  Initially, all the indicators will 
flash as a lamp test, ensure that there are no indicators which fail to light. 

The PASS/FAIL and B2 indicators will then flash to indicate that a self-test is in operation and then 
all the indicators except ‘Power’ will extinguish. 

The now ready to use. 

3.2.2 Connecting the circuit under test 

Using the supplied ISDN lead, plug one end into the connector marked ISDN BRI and the other end 
into an ISDN Network Terminator or any other RJ45 connector which carries an ISDN line.  If a 
correctly presented ISDN circuit is present, the Line indicator will come on to show that the unit is 
able to communicate at Layer 1 to the local exchange. 

3.2.3 Selecting the test 

In this mode, the B1, B2 and Pass / Fail indicators have a special function.  They enable the required 
test to be selected by repeatedly pressing the MODE / RUN button.  Each press of the button selects 
a different test. 

The required test is selected by matching the pattern of the indicators with the legend on the unit’s 
case.  For example, to perform a voice calling test would require that the B1 and B2 indicators are 
ON and the Pass / Fail Indicator is OFF.   
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The correct indicator combinations for all stand alone tests are shown below : 

 

Test Function B1 B2 Pass/Fail 

Data Call D Channel ON OFF OFF 

Data Call B Channel OFF ON OFF 

Outbound Voice Call ON ON OFF 

Inbound Voice Answering  OFF OFF ON 

Email logs to remote user ON OFF ON 

Line Voltage OFF ON ON 

 

3.2.4 Running the test 

When the required test is indicated, the MODE / RUN button is then pressed and held for 3 seconds 
to start the test cycle.   

What happens next depends on the test selected.  For example, the voice test will call a specified 
number and deliver a message saying that that test was successful.  If a data test was selected, the 
unit will attempt to set up a data circuit between the B1 and B2 channels. 

A full specification of the default tests as pre-configured from the factory are given in Chapter 4. 

3.2.5 Test Results 

Regardless of the test selected, the result is displayed on the Pass / Fail indicator together with a 
musical tone from the internal speaker as follows : 

• A GREEN indicator together with a rising tone indicates that all the programmed tests were 
performed satisfactorily. 

• A RED indicator together a descending musical tone indicates that one or more of the 
programmed tests failed.  A note is written to the error log which can be examined via the 
DTE port (see 2.3 below) 

3.2.6 Turning the Unit Off  

Your IT1000 is equipped with an ‘auto power off’ feature which will switch the unit off to conserve 
battery power whenever there has been no activity for a certain time.  The power off delay is user 
configurable and can be changed in IT1000 Explorer Options >Configure IT1000 menu. 
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ü You can defeat the auto power off feature by unchecking the Auto Power Off box in Options > Configure 
IT1000.  This is useful if you are using the IT1000 on a mains power supply, especially if the unit is being used 
remotely as it will prevent the unit from switching itself off. 

You can also manually switch the unit off.  To do this ensure the test selection is in the idle mode i.e. 
none of the test selection LEDS are on, then press and hold the green mode/run button.  The unit 
will then power off.  

3.3 IT-Explorer Mode 

The IT1000 can also be used as a sophisticated protocol analyser to determine the cause of problems 
on an ISDN line.  Details of how to do this are in chapter 3 of this document. 
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4 RUNNING THE IT- EXPLORER SOFTWARE 
 

4.1 Concepts 

If it is necessary to investigate problems on an ISDN line beyond the basic tests available in stand 
alone mode or if it is required to re-program the test parameters, such as the number to be called in a 
voice test, it is necessary to use the supplied IT-Explorer software. 

The software is designed to run on any PC which runs the Windows 98® or later operating system, it 
will also run satisfactorily on a Windows NT® platform. 

By means of the IT-Explorer software it is also possible to access a remote IT1000 in the field to 
determine the status of an ISDN circuit which may be hundreds of miles away, thereby saving 
unnecessary maintenance visits.  To enable IT-Explorer to make a physical link to the remote unit, 
you must have a PC or Laptop with an ISDN connection capable of making an outbound V.120 
connection.  (note: this can be another IT1000 with option 2 fitted). 

 

4.2 Installing the software 

The IT-Explorer software is supplied on a CD-ROM with the tester.   

To install it insert the disc into your CD-ROM drive and wait for the installation instructions to 
appear on your screen. 

The application software is very compact and takes less than 4Mb of space on your computer. 

 

4.3 Running IT-Explorer 

To use IT-Explorer to connect to a local IT1000 tester, firstly attach one end of the supplied cable to 
the port on the tester labelled DTE and the other end to a free serial port of your PC or laptop 
computer, then switch on the tested as described in Chapter 2. 

Z Be careful not to confuse the two ports on your tester.  Connecting an ISDN line to the DTE port can cause physical 
damage to your unit and should be avoided. 

You can also use the IT-Explorer software to connect to a remote tester.  This is very useful if you 
send a tester to a remote site and need to make it run tests from your PC and get instant confirmation 
of the results. 

The easiest way to connect to a remote tester is by using another IT1000 unit as they are 
preconfigured to operate in this way, however, any ISDN Terminal Adaptor capable of Multiframe 
V.120 can be used.  If you use a third part TA, ensure you correctly set the initialisation string (see 
4.4.2 Initialisation String) 
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If you have successfully installed the IT-Explorer software, you will find a new item added to your 
Windows START menu (START > PROGRAMS > BLACK BOX > IT1000 EXPLORER).  
Locate this and select it to launch the program.  Alternatively, you can start the program by locating 
the file IT1000explorer.exe and running it. 

The initial screen from which all functions are controlled looks like this : 

 

From this screen press the Connect button or chose the menu option Connection > Connect.  You 
will be presented with a screen like this which allows you to select a locally connected unit or a 
remote one. 

 

If you wish to connect to an IT1000 tester via the supplied serial cable, press Local Tester.  If you 
are attempting to connect to a remote tester, enter the ISDN number of the remote line in the Number 
box and press Remote Tester.   

The number drop down box contains the last 10 numbers you entered. 

When you ask to connect to a remote tester, you will be presented with a username and password 
login prompt like this: 
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You must enter the correct username / password combination for the particular unit you are dialling 
or your connection request will be refused.   

The default settings for the tester are : 

 Username : tester    

 Password : tester 

Note that the username and password are case sensitive and stored in the remote unit, not on your 
computer.  If they have been altered from their factory default settings, you will need to contact the 
owner of the remote unit to discover the username and password before you can log in to it. 

Z Be careful not to confuse the username and password of you own (local) unit with the username and password of 

the remote unit you are attempting to log in to.  

If the connection is successful, you will see the status indicator turn from red to either yellow for a 
remote unit or green for a local unit, like this : 

 

  

 

 You can now start to make tests. 
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From the drop down menu, select the required test from the list available.  In this case we have 
selected a B Channel Data Call on a locally connected unit : 

 

After selecting the test, you can configure the parameters by clicking on Configure Test.  In this 
case, you will see the following screen inviting you to select the number of the remote host, the 
Network User Address (NUA) and the Network User Identity (NUI) which the test call will be made 
to. 

 

Z Note that if you are connected to a local ISDN PABX rather than directly to an exhange line, you will need to 
include the dial-out access code (usually 0 or 9) to be able to call externally, otherwise the test will fail. 

When you have configured the required parameters for the test, you can go ahead and run it by 
clicking on the Run Test button. 
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When the test is starts to run, you will see a confirmation screen like this : 

 

The results of the test are displayed on the tester itself by means of the Pass / Err indicator and also 
on the connected computer by displaying one of the following screens : 

 

The tester will give an audible confirmation of the test result by means of its internal speaker and if 
the Enable Sounds option is enabled on the Options menu, you should also receive an audible 
confirmation via your computer’s built-in speaker. 

ü Whenever the spinning world logo is displayed the test being run can be cancelled by pressing the ESC key.  
Note that currently, this does not actually halt a D or B Channel test in progress, but does stop the unit 
waiting to display the results 

4.4 Options 

By means of the Options menu in IT-Explorer, you can change the way your tester operates. 

 

4.4.1 Com Port Settings 

It is important that you set the software to the correct COM port settings in order for the IT Explorer 
software to be able to communicate correctly with the unit.  These settings are contained within the 
options menu and can be accessed via Options > Com Port Settings. 

Z Note that it is not normally necessary to change any of these settings except to match the COM port to the one 
actually in use on your computer. 

 

4.4.2 Initialisation String 

With this option, you can send a Hayes® type command such as ‘ATE1’ (to enable echo) to the unit 
when it is initialised.  This option is used when the unit is in Terminal Adaptor mode. 
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Note several commands can be combined, but to actually send the command to the tester each 
command should be terminated by a “!” character which represents a carriage return e.g. 
ATS0=1!ATE1! 

4.4.3 Clear Analyser Trace before Each Test 

This option allows you to automatically clear the circular trace buffer before the start of each test.  
This allows you to focus your problem solving on only the results of that test, rather than also being 
able to see the results of previous tests and any other activity on the ISDN line. 

4.4.4 Enable Sounds 

By enabling this option, you will be able to hear audible confirmation that the test has completed 
satisfactorily or otherwise. 

Since this may be annoying in an office environment, the sounds can be turned off with this option. 

4.4.5 Configure IT1000 Analyser 

In this option, you can set general parameters about the IT1000, such as the length of time before it 
automatically powers off and the unit’s identity name.  The configuration screen looks like this : 

 

You can also defeat the auto power off circuit by unchecking the ‘Auto Power Off’ box.  This 
function is useful if you have a lot of setting up to do or you are using the unit as a terminal adaptor. 

By using the Voice message option, you can change the voice message which is played during the 
Voice Answering and Voice Calling tests from the factory default to a message of your choice. 

The Tester Tones box allows you to change the tones played by the tester from the normal musical 
notes to tones which may be more useful in a noisy environment. 
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4.4.6 Set Time  

Your IT1000 tester is equipped with a battery backed real time clock which has a resolution of  ± 10 
mS.  This allows data written to the analyser log to be date and time stamped for future analysis. 

You can use the Options > Set Date / Time option to set the correct time in the unit.  By selecting 
this option, a calendar appears with today’s date and time as taken from your PC’s clock.  Click on 
‘Set Time’ to transfer this date and time to your IT1000 unit.   

Once set the battery will continue to operate the real time clock for up to 30 days even if there is no 
other power source. 

4.4.7 Configure Analyser 

When your unit is shipped from the factory, it is set to capture all activity on the ISDN line at Layer 
1 (Physical), 2 and 3 (LAPB & LAPD).  If you are using the tester to home in on a particular 
problem, it can be confusing to be presented with so much information. 

This option, therefore, allows you to select which analysis is written to the analyser log.  By using 
this option together with selective use of the ‘Clear Analyser Trace Before Each Test’ option (on 
the Options Menu), you can easily identify specific issues. 

 

Notice from the above that you can also capture Raw ISDN Sync data on the D / B1 and B2 
channels, this is useful for non-packet mode protocols such as V.120.  By checking the 
Asynchronous Port checkbox, you can also capture the data between your computer and the tester.  
This mode is normally only used when the tester is used as a Terminal Adaptor.  
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4.4.8 Configure Automatic Emails 

Z To send emails, you must have an account with an Internet Service Provider. 

One of the principal features provided by the tester is the ability to automatically generate and send 
an email each time an event of a specified priority, or higher, occurs. 

This feature works by calling up an Internet Service Provider (ISP) or your organisation’s own 
SMTP mail gateway and establishing a connection with an SMTP server. It then sends an e-mail 
which has the unit’s event log and protocol analysis as text file attachments. 

Options to configure this feature are contained in Options > Configure Automatic Emails.   You 
will be presented with a screen with three tabbed boxes like this : 
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You should enter the following information : 

 

To e-mail address The address you want automatic e-mails to be sent to.  Note 
this does not have to be the same as the address where on-
demand emails are sent, these are configured from the 
Configure Test button on the main screen 

From e-mail address This field must contain an email address in a valid internet 
format i.e. name@domain.country.orgtype.  When emails are 
received from the unit they will appear to come from this 
address even if it does not physically exist.  If this field is left 
blank many SMTP servers will reject the message. 

Subject The entry here will appear in the subject field of the e-mail 
sent 

Max emails/day In order to prevent rogue units sending high numbers of 
unwanted emails, this field can be set to limit the maximum 
number that can be sent in one day. 

Email trigger priority An email is sent when an event equal or higher priority to the 
number in this field is encountered.  The actual priorities are 
predefined, but can be changed in the Event Codes tab box 
(see below). 

SMTP server  Enter here the address of the SMTP server which you use to 
send emails.  This information can be obtained from your ISP 
or by checking the settings in your regular email client. 

ISP Number Enter here the telephone number which you dial to connect to 
your ISP 

ISP User Name This field must contain the username by which you log into 
your ISP.  Do not confuse this with your POP3 / IMAP email 
login details. 

ISP Password  Enter the password which is associated with your ISP User 
Name.  Please note that the characters typed are not displayed, 
so you must type them carefully. 

ü If you do not wish the tester to send automatic e-mails i.e. only to send emails when commanded to do so 
through the front panel or the IT1000 Explorer main menu, then set the maximum number of e-mails per day 
to zero.
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ü The automatic email facility works in conjunction with the event logger The event codes tab box enables 
priorities on individual events to be changed, by clicking on the Event Codes tab you will be presented with the 
following screen : 

 

 

On each line, the first number represents the unique event code which is allocated by the tester and 
should not be changed.  The second number is the event priority.  Priorities can range from 0 to 9 
with 9 being the highest priority.  The third item on each line is the actual character string associated 
with each event, these can be changed, but it is normally recommended to leave these at the factory 
settings. 

You will notice that some events have reason codes associated with them, for example, event code 
05 in the example above represents a protocol layer going down.  There may be several reasons for 
this and they are allocated the reason codes below e.g. Event Code 05, Reason Code 01 means that 
the layer went down due to inactivity on the circuit. 

When you click OK, any changes you made will be saved to the tester. 
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The actual email sent can also be configured.  This is done from the Email Template tab. When you 
click this tab the following dialogue appears :  

 

Note that the email format supports parameter substitution and the easiest way to insert these 
parameters is by placing the cursor where you wish them to appear and right-clicking the mouse.  
Select the required parameter from the dialogue box which appears. 

4.4.9 Save Changes to Tester 

Your IT1000 tester is equipped with Non-Volatile Flash memory and a battery backed real time 
clock.  However, changes to the tester are not made permanent until you chose this option.   

Use this option every time you make changes to the configuration of your tester, otherwise they will 
be lost and future tests may give confusing results. 

ü This means that you can experiment with different settings in order to diagnose a problem and then easily 
return to the previously saved setting by simply turning the tester off then on again. 

Z Note that in common with other devices which use flash memory, you should not interrupt the power supply whilst 
the new configuration is being committed to memory.  Doing so may mean that your tester has to be returned to 
Black Box for service. 
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5 INDIVIDUAL TEST DETAILS 

 

5.1 Introduction 

This section describes the individual tests which your IT1000 tester can perform in further detail.  To 
select a test in stand-alone mode, ensure that the test selection indicators are set to the correct value 
as in 2.2.3 above 

5.2 D Channel Activity Monitor 

When the unit is connected to a functioning ISDN line with D Channel active, the ‘Line Active’ 
LED will automatically illuminate to show that an ISDN line is present. 

5.3 D Channel Data Call 

This test attempts to make a call to a nominated X.25 host.  It first checks for a functioning Layer 2 
circuit to the local exchange then attempts to send SAPI 16 traffic over the D Channel. 

If this succeeds, the test will then send a request for information over X.25 to the remote host.  The 
host used is configurable and is set at the factory to query the BT test clock, this can be changed to 
any host whose NUA (Network User Address) you have, but if you do this you should note the 
factory parameters before changing it. 

The test will be considered successful if the remote host returns properly formatted X.25 data over 
the D channel. 

5.4 B Channel Data Call 

This test attempts to make a call to a nominated X.25 host using any available ISDN B channel.  It 
first checks for a functioning Layer 2 circuit to the local exchange then attempts to call a remote 
X.25 PAD. 

On receiving a call connect message from the remote PAD, it then attempts to send a request for 
information to a nominated remote host. 

The test will be considered successful if the remote host returns a properly formatted response over 
the B channel. 

5.5 Voice Call (outgoing) 

When this test is selected, the tester attempts to dial a specified voice number using any available B 
channel.  The number to be called is programmed by using the IT-Explorer software and is 
remembered in the unit even when it is switched off. 
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The unit will continue to ring the specified number for 30 seconds or until the call is answered.  On 
answering the tester will play a pre-recorded voice message announcing itself to the person who 
answered the call and the test will be considered successful. 

If the tester is unable to dial the number either due to an incorrectly programmed circuit or a B 
channel being unavailable, the test will fail.  To cancel the voice answering (outgoing) test, briefly 
press the Mode/run button or in IT-Explorer mode, press the ESC key. 

5.6 Voice Answering (incoming) 

When this test is selected, the tester waits for an incoming voice call .  When an incoming voice call 
is received, the tester picks it up and plays a pre-recorded message to the caller.  The test is then 
considered successful.  To cancel the voice answering (incoming) test, briefly press the Mode/run 
button or in IT-Explorer mode, press the ESC key. 

5.7 Line Voltage  

This test measures the voltage apparent on the line from the local exchange or the PABX if the line is 
not directly connected to the exchange. 

In stand alone mode, an indication of the voltage is given as a bar graph on the indicators.  Note that 
a voltage less than 10 Volts is indicated by only the Power indicator being on (i.e. no voltage 
indicators) and any voltage over 70 Volts is indicated by all the indicators being on. 

Z The tester is only to be used to test voltages on an ISDN line in the manner described.  ISDN lines carry a 
maximum voltage of 90V.  Under no circumstances must the tester be used as a general test instrument as this could 

prove hazardous to the operator. 

In IT-Explorer mode, the tester will display a more accurate reading of the line voltage on your 
computer screen. 

5.8 Email Logs   

This test function is intended to be used when any of the preceding tests have failed and further 
analysis is required by specialised support persons.   

This function is selected on the indicators and the selection button on the tester is pressed and held 
down for at least 3 seconds.  The tester will then attempt to establish a PPP connection with an 
Internet Service Provider then send an email to the pre-configured address. 
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Make sure that before attempting to send e-mails you have configured the unit for an ISP where you 
have a valid account or this test will fail. Configuring this is a three step process : 

STEP 1  - Connect to the tester 

Use the IT-Explorer software to connect to your local tester as described in Section 2 

STEP 2  - Configure your SMTP Server 

Use the drop down ‘Select Test’ menu to select the Send Email test, then click on the 
Configure Test button.  Fill in the blank fields with the appropriate information.   

STEP 3  - Save Changes 

The changes just made will be lost when the power is removed from your unit unless they are 
permanently saved using Options > Save Changes to Tester. 

When you have completed these three steps the unit will be able to send e-mails on demand from the 
front panel buttons or by the Run Test option in IT-Explorer. 

By default the email contains the event log and a protocol analysis of the Layer 1,2 and 3 events at 
the time the e-mail is requested, but you can change this by using the IT-Explorer software. 

 

5.9 Record New Voice Message 

It is possible to change the voice message played when the unit is used in Voice Answer or Voice 
Call mode.  To do this select Record new voice message from the Options menu and follow the 
instructions given. 

You will be asked to enter a telephone number and the unit will use this number to call you.  You 
will need to be in sight of the screen when the unit calls. When you pick up the handset immediately 
begin to record your new message then click the Hang Up button on your PC. 

The unit will then compress the voice and store it in the flash memory. 

You can toggle between the Factory default message and the ‘Custom’ message by using  Options > 
Configure IT1000. 
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Appendix A – Async (DTE) port connector 

 

The illustration and table below show the pin numbering for the serial port RJ45 connector as seen 
from the side of the unit and the pin designations respectively.  

 

  

 

 

RJ45 Pin Description RS232 signal 

1 Ready to Send RTS 

2 Data Terminal Ready DTR 

3 Receive Data RXD 

4 Data Set Ready DSR 

5 Ground GND 

6 Transmit data TXD 

7 Data Carrier Detect DCD 

8 Clear To Send CTS 
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Appendix B - Specifications 

Physical  

Size 32mm x 91mm x 146 mm 

Weight 220g including battery 

Case High impact ABS plastic 

Power 

9VDC by rechargeable NiMh or disposable IEC6F22 (PP3) battery 

12VDC by external power supply (Black Box type 5412-1200) 

Interfaces 

ISDN Basic Rate S0 bus to CCITT 1.430 on 8 pin RJ45 

RS-232 serial port on 8 pin RJ45 (RJ45 to 9 pin D type adaptor supplied)  

 

Tests Performed 

Line Power OK Voice call to specified number 

Layer 1 Traffic Active Voice call to unit from any number 

Layer 2 SAPI 0 Traffic Send analyser trace by email 

Layer 2 SAPI 16 to exchange Send e-mail on specified event  

Call to X.25 Host Collect statistics on Sync channels  

Line Voltage 0 – 100V input  

 

Statistics Collected 

X.25 

TX Calls Rx Calls Tx Restarts Rx Restarts 
Rx Packets Rx Bytes Tx Packets  Tx Bytes 

LAPD 

TEI Rx Packets Tx Packets Rx Rejects 
Unsolicited Responses Rx Bytes Tx Bytes  Tx Rejects 
Rx SABME Tx SABME Re-transmits TEI removals 
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LAPB 

Dials Rx Packets Tx Packets Rx Rejects 
Re-transmits Rx Bytes Tx Bytes  Tx Rejects 
Rx SABME Tx SABME   

Sync Channels 

Rx Runts Rx Packets Tx Packets Underruns  
Rx Giants Rx Bytes Tx Bytes  Tx Rejects 
Rx CRC Errors Messages Short Buffer Shortages 
Rx Overruns  Rx Aborts 
 

 

Recommended Minimum PC Hardware  

Microsoft Windows 95 / 98 / NT 

Pentium Class CPU with a minimum of 32Mb RAM  

5Mb Hard Drive space available 

VGA display 

 

Remote Access  

Requires an ISDN Terminal Adaptor capable of V.120 Multiframe or another Black Box IT1000 
tester and a functional ISDN line. 
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