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Trademarks Used in this Manual

Trademarks Used in this Manual

Black Box and the Double Diamond logo are registered trademarks, and
ServSwitch is a trademark, of BB Technologies, Inc.

Mac is a registered trademark of Apple Computer, Inc.

IBM is a registered trademark of International Business Machines Corporation.
Java is a registered trademark of Oracle Corporation.

TOSLINK is a registered trademark of Toshiba Corporation.

Any other trademarks mentioned in this manual are acknowledged to be
the property of the trademark owners.

NOTE: The ServSwitch DKM FX and the ServSwitch DKM FX Compact function in
similar ways. The difference between them is described in the table below.

Table 1. ServSwitch DKM FX and DKM FX Compact comparison.

ServSwitch DKM FX Compact  ServSwitch DKM FX

Number of Ports  16-, 32-, 48-port options 48-, 80-, 160-, 288-port options

Type of Ports CATx I/0 ports only CATx/fiber 1/0 ports dependent on 1/O card
Form Factor Small form factor (1U) Large form factor (4U+)

Modular or Not Not modular Modular
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FCC and IC RFI Statements/NOM Statement

FEDERAL COMMUNICATIONS COMMISSION AND
INDUSTRY CANADA RADIO FREQUENCY INTERFERENCE STATEMENTS

This equipment generates, uses, and can radiate radio-frequency energy,

and if not installed and used properly, that is, in strict accordance with the
manufacturer’s instructions, may cause interference to radio communication.

It has been tested and found to comply with the limits for a Class A computing
device in accordance with the specifications in Subpart B of Part 15 of FCC rules,
which are designed to provide reasonable protection against such interference
when the equipment is operated in a commercial environment. Operation of
this equipment in a residential area is likely to cause interference, in which case
the user at his own expense will be required to take whatever measures may be
necessary to correct the interference.

Changes or modifications not expressly approved by the party responsible
for compliance could void the user’s authority to operate the equipment.

This digital apparatus does not exceed the Class A limits for radio noise
emission from digital apparatus set out in the Radio Interference Regulation
of Industry Canada.

Le présent appareil numérique n'émet pas de bruits radioélectriques dépassant les
limites applicables aux appareils numériques de la classe A prescrites dans le
Reglement sur le brouillage radioélectrique publié par Industrie Canada.

Normas Oficiales Mexicanas (NOM)
Electrical Safety Statement
INSTRUCCIONES DE SEGURIDAD

1.Todas las instrucciones de seguridad y operacion deberan ser leidas antes
de que el aparato eléctrico sea operado.

2. Las instrucciones de seguridad y operacion deberan ser guardadas para
referencia futura.

3. Todas las advertencias en el aparato eléctrico y en sus instrucciones de
operacion deben ser respetadas.
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NOM Statement

4.

5.

10.

11.

12.

13.

14.

15.

16.

Todas las instrucciones de operacion y uso deben ser seguidas.

El aparato eléctrico no debera ser usado cerca del agua—por ejemplo,
cerca de la tina de bafio, lavabo, sétano mojado o cerca de una alberca,
etc.

El aparato eléctrico debe ser usado Unicamente con carritos o pedestales
gue sean recomendados por el fabricante.

. El aparato eléctrico debe ser montado a la pared o al techo sélo como sea

recomendado por el fabricante.

Servicio—El usuario no debe intentar dar servicio al equipo eléctrico mas alla
lo descrito en las instrucciones de operacién. Todo otro servicio debera ser
referido a personal de servicio calificado.

El aparato eléctrico debe ser situado de tal manera que su posicién no
interfiera su uso. La colocacién del aparato eléctrico sobre una cama, sofa,
alfombra o superficie similar puede bloquea la ventilacién, no se debe
colocar en libreros o gabinetes que impidan el flujo de aire por los orificios
de ventilacion.

El equipo eléctrico deber ser situado fuera del alcance de fuentes de calor
como radiadores, registros de calor, estufas u otros aparatos (incluyendo
amplificadores) que producen calor.

El aparato eléctrico debera ser connectado a una fuente de poder soélo del
tipo descrito en el instructivo de operacion, o como se indique en el
aparato.

Precaucion debe ser tomada de tal manera que la tierra fisica y la
polarizaciéon del equipo no sea eliminada.

Los cables de la fuente de poder deben ser guiados de tal manera que no
sean pisados ni pellizcados por objetos colocados sobre o contra ellos,
poniendo particular atencion a los contactos y receptaculos donde salen
del aparato.

El equipo eléctrico debe ser limpiado Unicamente de acuerdo a las
recomendaciones del fabricante.

En caso de existir, una antena externa debera ser localizada lejos de las
lineas de energia.

El cable de corriente debera ser desconectado del cuando el equipo no sea
usado por un largo periodo de tiempo.
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NOM Statement

17.

18.

Cuidado debe ser tomado de tal manera que objectos liquidos no sean
derramados sobre la cubierta u orificios de ventilacion.

Servicio por personal calificado deberé ser provisto cuando:

A: El cable de poder o el contacto ha sido dafado; u

B: Objectos han caido o liquido ha sido derramado dentro del aparato; o
C: El aparato ha sido expuesto a la lluvia; o

D: El aparato parece no operar normalmente o muestra un cambio en su
desempeno; o

E: El aparato ha sido tirado o su cubierta ha sido dafiada.
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Safety Instructions

Safety Instructions

For reliable and safe long-term operation of your ServSwitch DKM FX, follow these
guidelines:

Installation
e Only use in dry, indoor environments.

¢ The ServSwitch DKM FX and the power supply units can get warm. Don’t put them
in an enclosed space without any airflow.

e Do not obscure ventilation holes.

¢ Only use power supplies originally supplied with the product or manufacturer-
approved replacements. Do not use a power supply if it appears to be defective or
has a damaged case.

e Connect all power supplies to grounded outlets. In each case, make sure that the
ground connection is maintained from the outlet socket to the power supply’s AC
power input.

¢ Do not connect the link interface to any other equipment, particularly network or
telecommunications equipment.

¢ Only connect devices to the serial interface that are sufficiently secured against
short circuits and false voltages at the serial interface.

¢ To disconnect the switch from the power supply, remove the power cords of all
power supply units that are in use or set the power switch (if available) to the OFF
position.

e Take any required ESD precautions.

Repair
e Do not attempt to open or repair a power supply unit.

¢ Do not attempt to open or repair the ServSwitch DKM FX. There are no
user-serviceable parts inside.

e Contact Black Box Technical Support at 724-746-5500 or info@blackbox.com
if there is a fault.
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Chapter 1: Specifications

1. Specifications

1.1 Interfaces

1.1.1 DVI-D Single Link

The video interface supports the DVI-D protocol. All signals that comply with
DVI-D single-link standard can be transmitted. This includes, for example, monitor
resolutions such as 1920 x 1200 @ 60 Hz, Full HD (1080p), or 2K HD (up to 2048
x 1152). Data rate is limited to 165 MPixel/s.

1.1.2 USB HID

Devices with USB HID interface support a maximum of two devices with
USB HID protocol. Each USB HID port provides a maximum current of 100 mA.

Keyboard

Compatible with most USB keyboards. Certain keyboards with additional
functions may require custom firmware to operate. Keyboards with an integral
USB Hub (Mac® keyboards, for example) are also supported.

Mouse
Compatible with most 2-button, 3-button, and scroll mice.
Other USB HID devices

The proprietary USB emulation also supports certain other USB HID devices, such
as specific touchscreens, graphics tablets, bar-code scanners, or special keyboards.
Support cannot be guaranteed, however, for every USB HID device.

NOTE: Only two USB HID devices are supported concurrently, such as keyboard
and mouse or keyboard and touchscreen. A hub is allowed, but it does not
increase the number of HID devices allowed.

To support other USB “non-HID" devices, such as scanners, Web cams or memory
devices, choose our devices with transparent USB support.

1.1.3 RJ-45 (Network)

CATx device communication requires a T000BASE-T connection. Pin the cable
according to EIA/TIA-568-B (1000BASE-T) standard with RJ-45 connectors at both
ends. All four wire pairs are used in both directions. The cabling is suitable for
full-duplex operation. For the cable connection to a source (computer, CPU), use a
cross-pinned network cable.
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Chapter 1: Specifications

1.1.4 RS-232 (Serial)

The communication takes place with a transmission speed of up to 115.2 kbps,
regardless of the file format, eight data bits and a stop bit, but without a parity
bit. Limited hardware handshake (DSR) is possible.

1.1.5 RJ-45 (Interconnect)
CATx device communication requires a T000BASE-T connection.

Connector wiring must comply with EIA/TIA-568-B (1000BASE-T), with RJ-45
connectors at both ends. All four wire pairs are used.

1.1.6 Fiber SFP Type LC (Interconnect)

Fiber device communication is performed via Gigabit SFPs connected to suitable
fibers fitted with LC connectors (see Section 1.2.2).

NOTE: The correct function of the device can only be guaranteed with SFPs
provided by Black Box.

CAUTION: SFP modules can be damaged by electrostatic discharge (ESD). Follow
ESD handling precautions.

1.1.7 SDI (Interconnect)

SDI device communication requires a mini coax connection with mini BNC
connectors or 3G SFPs with transmission speeds of 0.360 Gbps (SD-SDI, SMPTE
259M), 1.485 Gbps (HD-SDI, SMPTE 292M), and 2.70 Gbps (3G SDI).

1.2 Interconnect Cable

1.2.1 CATx

NOTE: A point-to-point connection is required. Operation with several patch fields
is possible. Routing over an active network component, such as an Ethernet
hub, router, or ServSwitch DKM FX, is not allowed.
* Avoid routing CATx cables along power cables.
e /f the site has three-phase AC power, make sure that the CPU Unit and

CON Unit are on the same phase.

NOTE: To maintain requlatory EMC compliance, use correctly installed shielded
CATx cable throughout the interconnection link.

NOTE: To maintain requlatory EMC compliance, all CATx cables need to carry
ferrites on both cable ends close to the device.

Type of Interconnect Cable

The ServSwitch DKM FX requires interconnect cabling specified for Gigabit
Ethernet (1000BASE-T). Use solid-core (24 AWG), shielded, CAT5e (or better)
cable.
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Chapter 1: Specifications

Table 1-1. CATX interconnect cable.

Cable Type Description
This S/UTP (CAT5e) cable confoms to EIA/TIA-568-B.
CATx solid-core 24 AWG cable Uses four pairs of 24 AWG wires. Connects according

to EIA/TIA-568-B (1000BASE-T).
This S/UTP (CAT5e) cable confoms to EIA/TIA-568-B.

CATx solid-core 26/8 AWG cable Uses four pairs of 26/8 AWG wires. Connects according
to EIA/TIA-568-B (1000BASE-T).

NOTE: You can use use type 26/8 AWG flexible cables (patch cables), but the
maximum possible extension distance is cut in half.

Table 1-2. Maximum acceptable cable length.

Cable Type Distance

CATx 24 AWG installation cable 400 ft. (140 m)

CATx 26/8 AWG patch cable 200 ft. (70 m)

1.2.2 Fiber

NOTE: A point-to-point connection is necessary. Operation with multiple patch
panels is allowed. Routing over active network components, such as
Ethernet hubs, ServSwitch DKM FXes, or routers, is not allowed.

Type of Interconnect Cable

Table 1-3. Fiber interconnect cable.

Cable Type Description

Single-mode. 9-um e Two fibers, 9-um
9 2 ¢ In-house patch cable (EFN092)
e Two fibers, 50-uym

Multimode 50-ym * In-house patch cable (EFN6020)

¢ Two fibers, 62.5-uym

Multimode 62.5-um | In-house patch cable (EFN116-LCLC)

NOTE: Only use single-mode cables for fiber connections that are based on 3G
SFPs.
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Table 1-4. Maximum acceptable fiber cable length.

Cable Type Distance
Single-mode 9-um 32,800 ft. (10,000 m)
Multimode 50-pym (OM3) 3280 ft. (1000 m)
Multimode 50-pm 1300 ft. (400 m)

Multimode 62.5pm 650 ft. (200 m)

NOTE: If you use single-mode SFPs with multimode fiber optic cable, you can
double the maximum acceptable cable length.

Type of Connector
The fiber cable uses LC connectors.

1.2.3 Coaxial
NOTE: A point-to-point connection is necessary.

Table 1-5. Coaxial interconnect cable.
Cable Type Description

RG-6

Mini coaxial cable, 18 AWG e 75 el

Table 1-6. Maximum acceptable coaxial cable length.
Bandwidth Distance

0.270 Gbps 1312 ft. (400 m)
1.485 Gbps 459 ft. (140 m)

2.970 Gbps 394 ft. (120 m)

Type of Connector

The coaxial cable uses mini BNC connectors.
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1.3 Supported Peripherals

You can use the KVM extenders described in Tables 1-7 and 1-8 with the
ServSwitch DKM FX:

Table 1-7. KVM extender with CATx connection.

Product Code Description

ACX1T-11-C KVM CPU unit, single-head, 2x USB HID

ACX1R-11-C KVM CON unit, single-head, 2x USB HID

ACX1T-11V-C KVM CPU unit, single-head, DVI-I input (VGA), 2x USB HID

ACX1R-11V-C KVM CON unit, single-head, IR receiver, 2x USB HID

Table 1-8. KVM extender with fiber (single-mode) connection.

Product Code  Description

ACX1T-11-SM KVM CPU unit, single-head, 2x USB HID

ACXI1R-11-SM KVM CON unit, single-head, 2x USB HID

ACX1T-11V-SM KVM CPU unit, single-head, DVI-I input (VGA), 2x USB HID

ACX1R-11V-SM  KVM CON unit, single-head, IR receiver, 2x USB HID

1.4 Connector Pinouts
1.4.1 CPU Board

HHEOR

Figure 1-1. DVI-D single-link connector.
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Table 1-9. DVI-D single-link connector pinout.

Pin Signal Pin Signal Pin Signal
1 T.M.D.S. data 2- 9 T.M.D.S. data 1- 17 T.M.D.S. data 0-
2 T.M.D.S. data 2+ 10 T.M.D.S. data 1+ 18 T.M.D.S. data 0+
3 T.M.D.S. data 2 GND 1" T.M.D.S. data 1 GND 19 T.M.D.S. data 0 GND
4 Not connnected 12 Not connected 20 Not connected
5 Not connected 13 Not connected 21 Not connected
6 DDC input (SCL) 14 +5 VDC high impedance 22 T.M.D.S. GND
7 DDC output (SDA) 15 GND 23 T.M.D.S. clock+
8 Internal use 16 Hot plug recognition 24 T.M.D.S. clock-
C1 Internal use — — C3 Internal use
C2 Not connected c5 GND c4 Internal use
Table 1-10. USB Type A connector.
Picture Pin Signal Color
1 VCC (+5VDC) Red
ieo4 2 Data - White
3 Data + Green
4 GND Black
Table 1-11. DB9 connector.
Picture Pin Signal Color Signal
1 Not connected 6 DTR
| [— 5 2 cTS 7 ™D
3 RTS 8 RxD
Gl 9 4 DSR 9 Not connected
5 GND = —

Page 16
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Table 1-12. RJ-45 connector.

Picture Pin  Signal Color Signal
1 D1+ 5 Not connected
—_ —
2 D1- 6 D2-
3 D2+ 7 Not connected
- F— 1
4 Not connected 8 Not connected

1.4.2 1/0 Board CATx
Table 1-13. RJ-45 CATx connector.

Picture Pin  Signal Color Signal
1 D1+ 5 D3-
1 —
2 D1- 6 D2-
3 D2+ 7 D4+
: Fe— 1 4 D3+ 3 D4-

1.4.3 1/0 Board SFP
Table 1-14. RJ-45 connector.

Picture Diode Signal
1 Data OUT
[0 —
1 2 2 Data IN

1.4.41/0 Board SDI
Table 1-15. RJ-45 connector.

Picture Pin Signal
l 1 Data In
@ 2 GND
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1.5 Power Supply

Power — ACXC48, ACXC32, ACXC16: 90-240 VAC, 50-60 Hz internal power
supply;

All other models: Voltage: 100-240 VAC, 50-60 Hz;

ACX288, ACX288-PS: 202 W max. without I/0 boards;
ACX160, ACX160-PS: 188 W max. without /0 boards;
ACX080, ACX080-PS: 99 W max. without /0O boards;
ACX048: 94 W max. without 1/0 boards;
I/0 boards (ACXI08-C, ACXI08-SM, ACXIO8-SPF): 13 W max.

1.6 Environmental Conditions
Temperature Tolerance — +41 to +113° F (+5 to +45° C)

Storage Temperature — -13 to +140° F (-25 to +60° C)
Relative Humidity — Max. 80%, non-condensing

1.7 Size
Size — ACX288: 19"H x 22.8"W x 12"D (48.3 x 57.8 x 33 cm),
Shipping box: 25.6"H x 26.8"W x 29.9"D (65 x 68 x 76 cm);
ACX160: 19"H x 15.8"W x 12"D (48.3 x 40 x 33 cm),
Shipping box: 25.6"H x 26.8"W x 12"D (65 x 68 x 54 cm),
ACX080: 19"H x 7"W x 9.1"D (64 x 57 x 36 cm),
Shipping box: 25.2"H x 22.4"W x 21.3"D (64 x 57 x 36 cm);
ACX048: 19"H x 5.3"W x 9.1"D,
Shipping box: 25.2" x 22.4"W x 12.4"D (64 x 57 x 23.1 cm);
ACXC48, ACXC32, ACXC16: 1.7"H x 17.4"W x 16.9"D (4.4 x 44.4 x 42.9 cm)

1.8 Shipping Weight
Weight — ACX288: 76.2 Ib (34.6 kg) fully equipped,
Shipping box: 90.6 Ib. (41.1 kg);
ACX160: 60 Ib. (26.3 kg) fully equipped,
Shipping box: 69.9 Ib. (31.7 kg);
ACX080: 24.5 Ib. (11.1 kg) fully equipped,
Shipping box: 34.4 Ib. (15.6 kg);
ACX048: 19.6 Ib. (8.9 kg),
Shipping box: 26.7 Ib. (12.1 kg)
ACXC48: 9 Ib. (4.1 kg);
ACXC32: 8.8 Ib. (4 kg);
ACXC16: 8.6 Ib. (3.9 kg)
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2. Overview

2.1 Description

2.1.1 Application

The ServSwitch DKM FX is used to establish connections from consoles (monitor,
keyboard, mouse, and other peripheral devices) to various sources (computer,
CPU). In a maximum configuration, up to 288 independent ports can be defined
and switched either as a console or a CPU.

The ServSwitch DKM FX Compact is used to establish connections from consoles
(monitor, keyboard, mouse, and other peripheral devices) to various sources
(computer, CPU). In a maximum configuration, up to 16 (using the ACXC16), 32
(using the ACXC32), or 48 (using the ACXC48) independent ports can be defined
and switched either as a console or a CPU.

The ServSwitch DKM FX is mainly specified for the use with extenders that are
able to transmit video, KVM, and USB 2.0 signals. You can also use it as a video
matrix.

For the connection between the ServSwitch DKM FX and the peripheral devices,
such as KVM extenders or video sources, you can use CATX, fiber, or coaxial
cables.

The ServSwitch DKM FX serves as a repeater. You can place it up to 6.2 miles
(10 km) from the consoles and 6.2 miles (10 km) from the sources.

2.1.2 Access Options

You have the following options to access the ServSwitch DKM FX for
configuration and operation:

Table 2-1. Access options.

Access option  Symbol

0OsD

Java tool

Serial interface

RS232
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2.2 System Overview

A ServSwitch DKM FX system consists of a ServSwitch DKM FX or DKM FX
Compact and, for KVM applications, one or more CPU units/CON units. The
ServSwitch connects to the CPU units/CON units by interconnect cables or is con-
nected directly to the video devices when used as a video matrix.

The CPU units connect directly to the sources (computer, CPU), using the included
cables.

Monitor(s), keyboard, and mouse connect to the CON units.

The ServSwitch DKM FX and the CPU units/CON units communicate over CATX,
fiber, or coaxial interconnect cables. The ServSwitch DKM FX Compact and the
CPU units/CON units communicate over CATx cable.

Figure 2-1 shows the system overview. Table 2-2 describes its components.

o= E—

o= -

.
= - N
T T

2 3 4 3 5 6

Figure 2-1. System overview.

Table 2-2. System components.

Number Component

1 Source (computer, CPU)

2 CPU units

3 Interconnect cable

4 ServSwitch DKM FX

5 CON units

6 Console (monitor, keyboard, mouse)
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See Section 3.2 for installation examples.
2.3 Available Products

Table 2-3. Available products.

Number

Description

ServSwitch DKM FX

ACX048 ServSwitch DKM FX 48-port with control card and power supply
ACX080 ServSwitch DKM FX 80-port with control card and power supply
ACX160 ServSwitch DKM FX 160-port with control card and power supply
ACX288 ServSwitch DKM FX 288-port with control card and power supply

ServSwitch DKM FX Compact

ACXC16 ServSwitch DKM FX Compact 16-port
ACXC32 ServSwitch DKM FX Compact 32-port
ACXC48 ServSwitch DKM FX Compact 48-port

Accessories

ACXIO8-C 8-port CATX input/output (1/0) module
ACXIO8-SM 8-port single-mode fiber input/output (1/0) module
ACXIO8-SFP 8-port single-mode fiber SFP input/output (I/0) module
ACX288-CTL  ServSwitch DKM FX controller card

ACXSFPC CATx SFP module

ACXSFPS Single-mode fiber SFP module

ACX080-PS Power supply for ACX048 and ACX080
ACX160-PS Power supply for ACX160

ACX288-PS Power supply for ACX288

ACX080-FAN  Tray for 48/80 port console

ACX288-FAN  Tray for 160/288 port console

ACX-JAV DKM FX Java Switch and Preset License

ACX-SYS DKM FX SNMP Switch and Syslog License
ACX-CAS DKM FX Cascade License

ACX-API DKM FX API License

2.4 What's Included

Your package should contain the following items. If anything is missing
or damaged, contact Black Box Technical Support at 724-746-5500

or info@blackbox.com.
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ACX048, ACX80 ACX160, ACX288:

e (1) ServSwitch DKM FX (ACX048, ACX080, ACX160, or ACX288)
® (1) power cord per built-in power supply unit

¢ (1) DKM FX controller card

e (1) serial control cable

® (1) set of mounting accessories

e This users’ manual in PDF format and Java tool on CD-ROM

e (1) cross-wired CATx network cable

ACXC16, ACXC32, ACX(48:

® (1) ServSwitch DKM FX Compact (ACXC16, ACXC32, or ACX(C48)
® (2) U.S. power cords (one per built-in power supply unit)

® (2) mounting brackets

(1) RJ-45/DB9 adapter

e (4) rubber feet

e This users’ manual in PDF format and Java tool on CD-ROM
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2.5 Device Views
In Sections 2.5.1 through 2.5.4, Figures 2-2 through 2-5 illustrate the ServSwitch
DKM FX chassis models. Tables 2-4 through 2-7 describe their components.

2.5.1 ServSwitch DKM FX 288-Port
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Figure 2-2. Front view, ACX288.
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Table 2-4. ACX288 components.

Number Component

1 Slot for Power Supply Unit 1

2 Slot for Fan Tray 1

3 Slot for Power Supply Unit 2
4 Slot for Fan Tray 2

5 Slot for I/0 Boards 1-36

6 Slot for Power Supply Unit 3
7 Slot for CPU board

8 Grounding

2.5.2 ServSwitch DKM FX 160-Port
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Figure 2-3. Front view, ACX160.
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Table 2-5. ACX160 components.

Slot for Power Supply Unit 1

Slot for Power Supply Unit 2

Slot for I/O Boards 1-36

Slot for Power Supply Unit 3

Number Component

1

2 Slot for Fan Tray 1
3

4 Slot for Fan Tray 2
5

6

7 Slot for CPU board
8 Grounding

2.5.3 ServSwitch DKM FX 80-Port
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Figure 2-4. Front view, ACX080.

Table 2-6. ACX080 components.

Number Component

1 Slot for fan tray

2 Slot for Power Supply Unit 1
3 Slot for I/0 Boards 1-10

4 Slot for Power Supply Unit 2
5 Slot for CPU board

6 Slot for air filter

7 Slot for Fan Tray 2
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2.5.4 ServSwitch DKM FX 48-Port
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Figure 2-5. Front view, ACX048.

Table 2-7. ACX048 components.

Number Component

1 Slot for fan tray

2 Slot for Power Supply Unit 1
3 Slot for I/0 Boards 1-10

4 Slot for Power Supply Unit 2
5 Slot for CPU board

6 Slot for air filter

7 Slot for Fan Tray 2

In Sections 2.5.5 through 2.5.7, Figures 2-6 through 2-11 illustrate the ServSwitch
DKM FX Compact models. Tables 2-8 through 2-13 describe their components.

2.5.5 ServSwitch DKM FX Compact 48-Port
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Figure 2-6. Front view, ACXC48.
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Table 2-8. ACXC48 front-panel

components.
Number Component
1 1/O ports 1-16
2 1/O ports 17-32
3 1/0 ports 33-48
4 Serial connection (RJ-45)

5

Network connection (RJ-45)

: m HID ‘I’

o o

o o

Figure 2-7. Back view, ACXC48.

Table 2-9. ACXC48 back-panel

components.
Number Component
1 Power supply unit 1
2 Power supply unit 2
3 Grounding

724-746-5500 | blackbox.com
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2.5.6 ServSwitch DKM FX Compact 32-Port
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Figure 2-8. Front view, ACXC32.

Table 2-10. ACXC32 components.

Number Component

1 1/O ports 1-16

2 1/O ports 17-32

3 Serial connection (RJ-45)

4 Network connection (RJ-45)

‘0BUB, :

o o

1 2 3

Figure 2-9. Back view, ACXC32.

Table 2-11. ACXC32 back-panel components.
Number Component
1 Power supply unit 1
2 Power supply unit 2

3 Grounding
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2.5.7 ServSwitch DKM FX Compact 16-Port
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Figure 2-10. Front view, ACXC16.

Table 2-12. ACXC16 components.
Number Component
1 1/0 ports 1-16
2 Serial connection (RJ-45)

3 Network connection (RJ-45)

o o o

: m DID ‘|’

o o o

1 2 3

Figure 2-11. Back view, ACXC16.

Table 2-13. ACXC16 back-panel components.

Number Component

1 Power supply unit 1
2 Power supply unit 2
3 Grounding
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2.6 Diagnostics and Status

2.6.1 Status LEDs

The ServSwitch DKM FX and DKM FX Compact LED indicators are shown in
Figures 2-12 through 2-22, and described in Tables 2-14 through 2-25.

Figure 2-12. CPU board, front view.
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Table 2-14. Status LEDs on the CPU board.

Number

LED

Status 1

Status 2

Status

White

Blue flashing

Red flashing

Green flashing

Green

White

Red flashing

off

Description

CPU board is in registration process
Registration at the matrix is started
Registration is in progess
Operating condition

CPU board de-registered

CPU board is in registration process
Registration at the matrix is started

Operating condition

NOTE: Because of variations in the LED type, “white” may also appear as light
purple or light blue.

o —1

—2

CATx
Figure 2-13. LEDs on the 1/0O boards.
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Table 2-15. Status LEDs on the 1/0 boards.

Number LED Status Description
Light blue I/0 board in boot process
Red flashing I/0 board in registration process
1 Status 1
Green flashing ~ Operating condition, 1/0 board registered at the matrix
Green I/0 board de-registered (locking pin pulled out)
White I/0 board in boot process
Blue I/0 board in registration process
2 Status 2 ) Operating condition, communication active with CPU board
Blue flashing

active

Red flashing I/0 board de-registered (locking pin pulled out)

N_‘
"
o
| |
o —
| |
Cé)\@)g\@ o

o
— &

CATx SFP fiber SFP coax
Figure 2-14. Ports status LEDs on the 1/0 boards.

Table 2-16. Port status LEDs on the 1/0 boards.

Number LED Status Description
off Port not activated
1 Link status (green)  Flashing Port activated, no connection via interconnect cable
On Connection via interconnect cable OK, data traffic active
Off Port not activated
2 Link status (orange)  Flashing Port activated, no connection via interconnect cable
On Connection via interconnect cable OK, data traffic active
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——FAN TRAY ——

Figure 2-15. Status LEDs on the fan tray.

Table 2-17. Status LEDs on the fan tray.

Number LED Status  Description
1 Status 1 (green)  On Operating condition
Off Operating condition
2 Status 2 (blue)
On Error indication
Off Hot swap option deactivated
3 Hot swap (blue)
On Hot swap option activated
123

Figure 2-16. Status LEDs on the power supply unit (ACX288-PS or ACX160-PS).
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Table 2-18. Status LEDs on the power supply unit
(ACX288-PS or ACX160-PS).

Number LED Status  Description
1 AC input OK (green) On Operating condition
2 DC output OK (green)  On Operating condition
Off Normal temperature
3 O/T (yellow)
On High temperature

Figure 2-17. Status LEDs on the power supply unit (ACX080-PS).

Table 2-19. Status LEDs on the power supply unit
(ACX080-PS).

Number LED Status  Description

DC input OK (green) On Operating condition
1

DC output OK (green)  Off No power supply

Status LEDs on ACXC16, ACXC32, and ACXC48

N g

12

(A9
O

Figure 2-18. Status LEDs on ACXC16, ACXC32, and ACXC48.
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Table 2-20. Status LEDs on the ACXC16, ACXC32, and ACXC48.

Number LED Status
White

1 Status 2 Red flashing
off
White

Blue flashing
2 Status 1 Red flashing

Green flashing

Green

NOTE: Because LED type varies,

blue.

Description

CPU board is in registration process
Registration at the matrix is started
Operating condition

CPU boad is in registration process

Registration at the matrix is started
Registration is in process

Operating condition

CPU board de-registered

“white” might also appear as light purple or light

LAN Port LEDs on the ACXC16, ACXC32, and ACXC48
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Figure 2-19. LAN port LEDs on ACXC16, ACXC32, and ACXC48.

Table 2-21. LAN port LEDs on
ACXC16, ACXC32, and ACXC48.

Number LED

Status LED 1
(orange)

Status LED 2
(green)

Status Description

On Connection to network is available
Off No connection to network
Flashing  Data traffic is active

Off Data traffic is not active
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I1/0 Port LEDs on the ACXC16, ACXC32, and ACXC48

T —
1 e

o 2l N
12

Figure 2-20. I/0 port LEDs on ACXC16, ACXC32, and ACXC48.

Table 2-22. 1/0 port LEDs on
ACXC16, ACXC32, and ACXC48.

Number LED

1 Link status port 1

2 Link status port 2

Table 2-23. Status LEDs at the ports of the
ACXC16, ACXC32, and ACXC48 I/0 boards.

Number LED Status Description
Off Initialization

1 Link status ~ Green Connection via interconnect cable is OK, data traffic is active
Orange Extender is not recognized

Power Supply Unit LEDs on the ACXC16, ACXC32, and ACXC48

(0]

L PR

|
12

Figure 2-21. Power supply LEDs on ACXC16, ACXC32, and ACXC48.
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Table 2-24. Power supply unit LEDs of the
ACXC16, ACXC32, and ACXC48 1/0 boards.

Number LED Status Description

! Status PSU ~ On Operating condition
T(green)  off Power supply unit off

5 Status PSU~ ON Operating condition
2(green) o Power supply unit off

Fan Tray Status LEDs on ACXC16, ACXC32, and ACXC48
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Figure 2-22. Fan Tray Status LEDs on ACXC16, ACXC32, and ACXC48.

Table 2-25. Fan Tray Status LEDs on the ACXC16, ACXC32, and ACXC48.

Number LED Status Description

: Left Fan Status 1 On Error indication
(red) off Operating condition

5 Left Fan Status 2 On Operating condition
(Ereen) Off Fan off

5 Right Fan Status 2 On Operating condition
(green) off Fan off

. Right Fan Status 1 On Error indication
(red) Off Operating condition
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2.6.2 Port Status
The connections and the switching status between the various consoles and CPUs
are shown in this menu.

You can access the menu in two ways: OSD or Java.

Figure 2-23. OSD and Java icons.
OsD

An on-screen display (abbreviated OSD) is an image superimposed on a screen
picture, commonly used by modern television sets, VCRs, and DVD players to
display information such as volume, channel, and time.

Java® Tool

The current port configuration of the ServSwitch DKM FX is illustrated in this
menu.

Select “Status > Matrix View" in the task area in on-line mode.
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Figure 2-24. Menu Status—Matrix View screen, Example #1.
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Figure 2-25. Menu Status—Matrix View screen, Example #1.

Table 2-26. Connection status.

Color Description

Gray Port not connected
Yellow Video connection
Green KVM connection
Red Faulty Port

The symbol in Table 2-27 indicates the extender that is recognized and defined at
a certain port.
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Table 2-27. Extender recognized.

Description

Symbol
Port connected to a CPU unit

Port connected to a CON unit

..'.'= Port connected to a USB 2.0 CPU unit

cPU

& Port connected t a USB 2.0 CON unit
E Port is configured as a CON port for customer-specific applications.
el
E Port is configured as a CPU port for customer-specific applications.
L LU

e Red framed ports are defined as “fixed” (for example, for USB 2.0 connections).
e The port with four static blue squares is currently selected.

e If a port is selected, all the other ports will be shown transparently, except for
those ports that are connected to the currently selected port. To clear a selected
port, press the “Clear Selection” button.

e If there is a red cross shown on a port when switching by the matrix view, the
console chosen to be connected does not have access rights to the respective
CPU at this port.

NOTE: To show the extender information of the currently selected port in the right
part of the working area, press the left mouse button.

The information in Table 2-28 is available:
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Table 2-28. Extender information.

Symbol Description

Extender name  Name of the selected extenders

Extender type Type of the selected extender

Port ID Number of the selected port
Device name Name of the connected console or CPU
Connections Listing of assigned connections to the marked port (full access or video access)

NOTE: To open the context menu for the currently selected port with further
functions, press the right mouse button.

The context functions in Table 2-29 are available:
Table 2-29. Context functions.

Function Description

Open extender  The menu for definition of the currently selected extender is opened
Open device The menu for definition of the currently selected console or CPU is opened

Switch The menu for execution of switching applications is opened

To reload the Matrix View:
e Press the “F5” key of a connected keyboard.
e Execute “Edit > Reload” in the menu bar.

e Press the “Reload ” button in the tool bar.
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2.6.3 Extender OSD

All extenders used with the matrix switch have an individual OSD to display the
connection status of the console.

03001 CON_010123675
01003 MACOO1

Figure 2-26. Example view of extender OSD.

Table 2-30. Extender OSD information.

Field Description

CON Name of the extender’s individual console
CPU Name of the currently connected CPU
Full Access: The extender’s indivdual console has a KVM connection to the displayed CPU.
Video Access: The extender’s individual console has a video only connection to the displayed CPU.

Access  Private Mode: The extender’s individual console has a Private Mode connection to the displayed
CPU.

Not connected: The individual console is not connected to a CPU.
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NOTE: If the Mouse Connect or Keyboard Connect options are used, the name of
the console with keyboard/mouse control will be displayed at those
consoles that do not have K/M control at the moment. The console is
displayed in yellow under “Access.”

2.6.4 Network Status
The current network configuration is shown in this menu.

You can access the menu via OSD or Java:

Figure 2-27. OSD and Java icons.
OsD

Select “Status > Network” in the main menu.

|

VES
192.168.100.133
255.295.255.0
192.168.100.1
00:21:5F:02:00:16

VES
VES
VES
10.1.10.50
YES
10.1.108.50

VES YES YES YES YES
YES YES YES YES YES

Figure 2-28. Status—Network screen.
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The following information is shown in the Network Status menu:

Table 2-31. Network status.

Field Description
DHCP Information if the network settings are applied dynamically. Display Y (Yes) or N (No)
IP address Information about the IP address as provided manually or via DHCP
Subnet mask Information about the subnet mask as provided manually or via DHCP
Gateway Information about the gateway address as provided manually or via DHCP
MAC ID Information about the MAC address in the matrix
Java Tool

1. Select “Status > Matrix View" in the task area.
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Figure 2-29. Menu status—matrix view.
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2. Use the left-mouse button to click on the network port of the CPU board.
The corresponding network status will be shown in the right part of the
working area.

2.6.5 Firmware Status
The current firmware status of the installed boards is shown in this menu.

You can access the menu via OSD or Java:

108SFP

Figure 2-31. Menu status—firmware.
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Table 2-32. Menu status—firmware.

Field Description

Name Description of the modules

Type Type number

Ports Number of ports

Version  Complete description of the firmware version

Date Date of the firmware version

Status  Module status

Java Tool

1. Select Status > Slot Table in the task area.
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Figure 2-32. Menu Status—Slot Table.

2. To read the firmware status and store it locally (file extension .dtf), select
“Switch > Save Firmware Status to File...."

3. To read the overall status of the ServSwitch DKM FX and store it locally (file
extension .zip), select “Switch > Save Status to File...".

The various modules can expanded and retracted in the “Name” column by
clicking the left-mouse button on the plus or minus symbols to get a better
overview.
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Click on the plus resp. minus symbol in the upper right corner of the
working area to expand and retract all module information with one click
of the left-mouse button.

2.6.6 Firmware Status Extender
The current firmware status of the connected extenders is shown in this menu.

To access the menu, use the Java tool.

Figure 2-33. Java Tool icon.

The following information is shown in this menu:

Table 2-33. Menu status—firmware status extender.

Field Description

Name Description of the firmware
Type Type number

Ports Number of ports

Cur. Version  Complete description of the current firmware version

Cur. Date Date of the current firmware version
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Select “Status >EXT Firmware” in the task area.
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Figure 2-34. Menu status—EXT firmware.

2.7 Trace Function
All events—for example, activities and switching operations of the ServSwitch
DKM FX—are logged and displayed in this menu.

This function is used for diagnostic purposes.

You can request various trace views in the menu:

P—

0OsD

Figure 2-35. OSD icon.

The following information is shown in this menu:

Table 2-34. Trace menu function.

Field Description

Time Timestamp

Message Detailed description of the event
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Trace possibilities

e Select “Status > Trace |0 Board” in the main menu to check the events on your

current 1/0 boards.

e Select “Status > Trace Matrix” to check the ServSwitch DKM FX events.

2.8 Syslog Monitoring

This menu logs matrix activities, switching operations, and the surveillance of
function-critical components (such as fans or power supply units).

Click on the Java icon to access the menu:

Figure 2-36. Java icon.

To start Syslog Monitoring, proceed as follows:

Select the Monitoring symbol in the symbol bar.
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Figure 2-37. Monitoring Menu—Syslog.
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Logging system activities start when opening the Monitoring menu, and remain
active until the appropriate tab is closed.

During logging, the activities are written continuously into logging files and stored
locally. This process can be set with various options.

Options
Select Extras > Options in the menu bar and open the Syslog tab.

The following options are available:

Table 2-35. Syslog options.

Option Description

Log File Directory Default directory to store the log files.
Log File Name Default name of the log file to be saved.
Log File Extension Default extension for the log file.
Maximum Log File Size (KB) Allowed maximum size of a log file.

Maximum Number of Log Files  Allowd maximum number of log files.

NOTE: When the maximum log file size is reached, a new log file will be created.
When the maximum number of log files is reached, the oldest one will be
overwritten with the new information.

Filter Function

To filter relevant messages out of a number of logged activities of the matrix
switch, the Syslog Monitoring offers various filter options.

To set and activate a filter, follow these steps:
1. Set the desired filter option(s) by activating the respective checkbox(es).
2. Activate the filter settings by pressing the “Filter” button.

3. To deactivate an activated filter setting, press the “Clear” button.
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The following filter options are available:
Table 2-36. Filter options.

Option Description

Date Messages of a defined range will be filtered.
Facility Messages of a defined facility will be filtered.
Severity Messages of a defined severity will be filtered.
Host Messages of a defined host will be filtered.
Message Messages with defined text parts will be filtered.

NOTE: Filter options are not valid within the locally stored log files.
Recording Function
All messages shown in the Syslog are equipped with various recording functions.

* To store the messages shown in the Syslog (filtered or unfiltered), press the
“Save trace” button. The messages will be stored in a .txt file.

* To remove the messages shown in the Syslog, press the “Clear trace” button.

* To stop recording the messages, press the “Pause” button. To continue
recording, press the button again.

2.9 SNMP

Use SNMP to monitor all function-critical and safety-critical parts of the matrix
and to query their status. This function complies with the RFC 1157 standard.

NOTE: During SNMP monitoring, we strongly recommend that you use a
dedicated network to ensure access security.

You can access the menu via OSD or Java:

Figure 2-38. OSD and Java icons.
OsD
To activate SNMP via OSD, follow these steps:

1. Select “Configuration > Network” in the main menu.
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2. Set the option SNMP Agent to “Y"” (Yes) under Network Services. Activating
this option grants permission to run an active query of the SNMP agent.

3. Set the IP address of the SNMP server under Network Services. This enables
active sending of trap messages from the SNMP agent to the SNMP manager.

Java Tool
To activate SNMP via Java tool, follow these steps:
1. Select “System > Network” in the task area.

2. Activate the option SNMP Agent under SNMP. Activating this option grants
permission for an active query of the SNMP agent.

3. Set the IP address of the SNMP server under SNMP Server. This enables active
sending of trap messages from the SNMP agent to the SNMP manager.
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3. Installation
3.1 System Setup

NOTE: If you are a first-time user, we recommend that you set up the system
in the same room as a test setup. This will allow you to identify and solve
any cabling problems, and experiment with your system more conveniently.

Setup of the ServSwitch DKM FX
1. Install the CPU and I/0O boards.

2. Connect the keyboard, mouse, and monitor to the CPU board of the
ServSwitch DKM FX.

3. Connect the ServSwitch DKM FX to the power supply.

4. Open OSD via hotkey and log in with administrator rights in the main menu
under configuration (see Section 4.2.1).

5. Configure initially as requested.

NOTE: After configuring the system, we recommend that you save the
configuration by selecting Configuration > Save and restart the ServSwitch
DKM FX by selecting Restart Matrix.

6. Optional: Establish a network connection between the ServSwitch DKM FX and
the Java tool to set an extended configuration (see Section 4.2.2).

Setup of Extender

1. Connect the CON units to the ServSwitch DKM FX by using the interconnect
cables (CATx or fiber).

2. Connect the CON units to the input devices to be used (for example, keyboard
and mouse).

3. Connect the 5-VDC power supply units to the CON units.
4. Check the basic function of the CON unit by opening the OSD via hotkey.

5. Connect the source (computer, CPU) to the CPU unit of the extender by using
the provided connection cables.

6. Connect the CPU unit to the ServSwitch DKM FX by using the provided
interconnect cables (CATx or fiber).
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7. If you have a video matrix, connect the video source directly to the ServSwitch
DKM FX by using the interconnect cables (coax, fiber).

8. Connect the 5-VDC power supply units to the CPU units.
9. Start the system.

3.2 Example Applications

The ServSwitch DKM FX supports a flexible configuration of your system
environment:

For example, part of the ServSwitch DKM FX can be configured as a single-head
workstation, part as dual-head, or quad-head, or even as a video ServSwitch DKM
FX. You can also configure KVM and USB 2.0.

In addition to the access via OSD by the keyboard connected to the CPU board or
an extender CON unit, you have the following access options:

e via Java Tool
e via serial interface
A connection to common media controls is possible, too.

Sections 3.2.1 through 3.2.4 describe typical installations of the ServSwitch DKM
FX.
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3.2.1 KVM Matrix

In single-head mode, up to 288 ports can be used either as an input or as an
output port, depending on components and equipment. At the same time, all
users have non-blocking access (user access is not limited by the activities of
another user).

Figure 3-1. KVM using ServSwitch DKM FX application.

Table 3-1. Single-head KVM matrix components.

Number Description

1 Source (computers, CPU)

2 CPU units

3 Interconnect cable

4 ServSwitch DKM FX

5 CON units

6 Consoles (monitor, keyboard, mouse)

If you have a single-head console, you can also access a dual-head or quad-head
console. However, you can control the system only at Monitor 1.

Any signal source can be switched to any number of monitors that will show the
video signal at the same time. Even (optional) audio can be switched.
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3.2.2 Video Matrix

If you use the ServSwitch DKM FX as a video matrix, it can switch up to 288 input
ports to up to 288 output ports, depending on components and equipment.

Figure 3-2. Video using ServSwitch DKM FX application.

Table 3-2. Video matrix components.

Number Description

1 Video sources, for example, an SDI camera

Interconnect cable

ServSwitch DKM FX

AW N

Video sinks, for example, a monitor

3.2.3 Parallel Operation (Stacking)

If you have special configurations, especially at installations with several monitors
per workstation, or you need additional support for USB 2.0 transmission paths,
you can increase the number of CPUs and consoles connected using a parallel
operation (stacking) of several ServSwitch DKM FX devices.

One of the ServSwitch DKM FX matrices has to be defined as the master
ServSwitch DKM FX, and all the others have to be configured as slaves and must
be connected to the master ServSwitch DKM FX via a network.
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If you send a switching command via the OSD, the slave matrices will also switch.

NOTE: Switching of stacked devices might be delayed by several seconds.

Figure 3-3. Parallel operation (stacking) application.

Table 3-3. Parallel operation
(stacking) components.

Number  Description

1 Dual-head source computer, CPU

2 CPU units

3 Interconnect cable

4 ServSwitch DKM FX (master)

5 ServSwitch DKM FX (slave)

6 Network connection master/slave(s)

7 CON units

8 Console (two monitors, keyboards, and mice
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3.2.4 Cascading
For applications that exceed the number of available ports, you can extend the
system by cascading.

In this case, the ServSwitch DKM FX devices are connected by “tie lines.” The tie
lines are dynamically configured to support connections in both directions.

1 2 3 4 3 5 36 7

Figure 3-4. Cascading application.

Table 3-4. Cascading components.

Number  Description

1 Source (computer, CPU)

CPU units

Interconnect cable

ServSwitch DKM FX (master)

2
3
4 ServSwitch DKM FX (slave)
5
6

CON unit

7 Console (monitor, keyboard, mouse)
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4. Configuration

4.1 Command Mode

The ServSwitch DKM FX has a Command Mode that enables several functions via
keyboard command during normal use.

To enter Command Mode, use a hotkey sequence, and to exit Command Mode,
press <Esc>. While in Command Mode, the Shift and Scroll LEDs on the console
keyboard will flash.

NOTE: In Command Mode, normal keyboard and mouse operation will cease.
Only selected keyboard commands are available.

NOTE: If there is no keyboard command executed within 30 seconds after
activating Command Mode, it willl be automatically deactivated.

The following table lists the keyboard commands to enter and to exit Command
Mode and to change the hotkey sequence:

Table 4-1. Command mode components.

Function Keyboard command
Enter Command Mode (default)  2x <Right-Shift> (or hotkey)
Exit Command Mode <Esc>

<Left-Ctrl> + <Left-Shift> + <c>, <hotkey code>, <Enter>
Change hotkey sequence Since 8/10/2011:
<current hotkey> + <c>, <new hotkey code>, <Enter>

NOTE: <Key> + <Key> = Press keys simultaneously; <Key>, <Key> = Press keys
successively, 2x <Key> = Press key quickly, twice in a row (similar to a
mouse double-click).
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You can change the hotkey sequence to enter Command Mode. The following
table lists the hotkey codes for the available key sequences:

Table 4-2. Command mode components.

Hotkey code Hotkey

1 <Left-Ctrl> + <Left-Shift> + <i>

2 2x <Scroll>

3 2x <Left-Shift>
4 2x <Left-Ctrl>

5 2x <Left-Alt>

6 2x <Right-Shift>
7 2x <Right-Ctrl>
8 2x <Right-Alt>

NOTE: In a combined KVVM matrix/U-Switch configuration, choose different
hotkeys for the KVM matrix and the U-Switch.

Set freely selectable “Hotkey” (exemplary)

To set a freely selectable Hotkey (for example, 2x <space>), use the following
keyboard sequence:

<current “Hotkey">, <c>, <0>, <Space>, <Enter>
Reset “Hotkey”

To set a Hotkey back to the default settings of the extender, press the key
combination <Right-Shift> + <Del> within 5 seconds after switching on the CON
unit or plugging in a keyboard.

4.2 Control Options

The ServSwitch DKM FX contains an internal CPU that enables you to control all
functions from any console without the need for an external CPU or media
control.

You can access the ServSwitch DKM FX for configuration and operation in three
ways:

¢ via OSD
* via Java Tool

e via serial interface
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4.2.1 Control via OSD
|
0sD
Figure 4-1. OSD icon.

Via OSD (on-screen display), you set the configuration of the ServSwitch DKM FX
operating system. The settings of the Configuration menu are described in this
chapter. All other menus are described in later chapters.

You can enter the OSD of the ServSwitch DKM FX:

® via keyboard connected to the CPU board

® via keyboard connected to a CON unit of an extender

Entering OSD

1. Start Command Mode with the hotkey.

2. Press <o> to open OSD. You will see a list of all available CPUs as a start menu.
3. Press <Esc> to enter the main menu.

Leaving OSD

e Press <Shift> + <Esc> simultaneously. The OSD will close without any further
changes and the currently active CPU connection will display.
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Menu Structure

Figure 4-2. Menu structure.

The general layout of the OSD is structured into three areas:
o Upper status area (top-most two text lines)
e \Working area

o | ower status area (lowest two text lines)

Page 62 724-746-5500 | blackbox.com



Chapter 4: Configuration

Keyboard control

You can select between the following keyboard commands:

Table 4-3. Keyboard commands.

Keyboard
Function command
Left cursor—only within an input field or a switching screen <Cursor-Left>
Right cursor—only within an input field or a switching screen <Cursor-Right>

e In input fields: Line up (with wrap-around)
<Cursor-Up>
e In menus: Line up (without wrap-around)

e In input fields: Line down (with wrap-around)
<Cursor-Down>
¢ In menus: Line down (without wrap-around)

Previous page in menus with more than one page <Page-Up>
Next page in menus with more than one page <Page-Down>
Next input field <Tab>

Previous input field

<Left-Shift> + <Tab>

Next option in selection fields <+>
Previous option in selection fields <>
Switching in selection fields between two conditions, <Spaces
for example, between ON/OFF or Y(Yes)/N(No) P
 In menus with input fields: Save data

<Enter>
® In menus: Select menu item
e In menus with input fields: Cancel data

<Esc>

¢ In menus with selection fields: Go back to the superior menu
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Sorting Function

You can sort lists and tables in the Java Tool.

Table 4-4. Sorting functions.

Keyboard

Function command
Sort ID numbers in a descending order or in an ascending order by <F1>
pressing the keyboard command twice (ID)
Sort ID names in a descending order or in an ascending order by pressing

. <F2>
the keyboard command twice (Name)
Go to the next result in the list of results for the search field (Next) <F3>

Go to the previous result in the list of results for the search field (Previous) — <F3>

Refresh the currently shown list (Previous) <F4>
Refresh the currently shown field (Refresh) <F5>
Jump between the search field and the list of results (Find) <F6>

Password request

You have to log in with administrator rights to be able to set configurations.

Figure 4-3. Login Menu screen.
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Access to the configuration menu requires administrator rights. User login is
mandatory.
Table 4-5. Menu login parameters.

Field Input
User admin
Password admin

NOTE: For security reasons, change the administrator password as soon as
possible.

4.2.2 Control via Java Tool

=7

Figure 4-4. Java icon.
Requirements
If you want to use the Java tool, you need these items:

e Computer with an executable Java tool and an installed Java Runtime
Environment (JRE, version 1.6 or higher)

e Java Tool software

¢ Available network connection between the Java tool and the ServSwitch DKM
FX

NOTE: Contact your system administrator concerning JRE and network
connection.

Installation of the Java Tool

The Java tool is available as a single executable program file that does not require
a separate installation.

Copy the tool after receiving the file to a directory on your computer.

NOTE: If you do not have a Java tool, contact Black Box Technical Support
at 724-746-5500 or info@blackbox.com.
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Computer Connection to the ServSwitch DKM FX

NOTE: For a direct connection between the computer and ServSwitch DKM FX,
use a cross-wired network cable.

For a connection between the computer and ServSwitch DKM FX via
switch or hub, use a straight-pinned network cable.

Connect the network cable to the RJ-45 ports of the computer and CPU board of
the ServSwitch DKM FX.

Start of the Java Tool

Open the Java tool by a double click on the program icon or use the <Enter> key
on the keyboard.

Connection to the Matrix

NOTE: Administrator rights are required.

1. Open the Java tool.

2. Select Matrix > Connect in the menu bar.

3. Enter the IP address in the popup input field according to the network
configuration of the ServSwitch DKM FX.

4. Enter the user name and password for the ServSwitch DKM FX.

5. Confirm your inputs with the button “OK” or reject with “Cancel.”
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Figure 4-5. Menu Connection screen.
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NOTE: Up to 12 connections between the matrix and the Java tool can be
established at the same time because available sockets are limited.

Menu structure

Sub Mateix
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Figure 4-6. Example menu view (system-switch).

The menu structure of the Java tools is subdivided into various sections:

e Menu bar (top line)

e Toolbar (second line)

e Tab bar (third line)

® Task area (left menu section)

e Working area (right menu section)
e Status bar (bottom line section)

Operating Instructions

The operation of the Java tool is intuitive and corresponds to the user interface of

common operating systems.
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The Java tool contains its own support function.

You can activate or deactivate the integrated help texts in the working area of the
Java tool by checking the box in the upper right corner.

Mouse Control

You can select between the following mouse commands:

Table 4-6. Mouse commands.

Function

Mouse command

Menu selection, marking

Left mouse button

Open function-specific selection menus

Double-click the left mouse button

Open content-specific selection menus

Right mouse button

Keyboard Control

You can select between the following keyboard commands:

Table 4-7. Keyboard commands.

Function

Keyboard command

Cursor to the left

<Cursor Left>

Cursor to the right

<Cursor Right>

Line up

<Cursor Up>

Line down

<Cursor Down>

Previous page in input or status menus with more than one page

<Page Up>

Next page in input or status menus with more than one page

<Page Down>

Next field in input menus

<Tab>

Previous field in input menus

<Left-Shift> + <Tab>

e Switching in selection fields between two conditions (checkmark or not)

e Open already marked fields with editing or selecting capablility

<Space>

¢ In menus: data saving

* Menu item selection

<Enter>

o Leave tables

e Jump from tables into the next field

<Ctrl> + <Tab>
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Table 4-7 (Continued). Keyboard commands.

Function Keyboard command
* Leave tables <Ctrl> + <Left-Shift> +
<Tab>

¢ Jump from tables into the previous filed

NOTE: Various functions within the menus in the menu bar can be executed with
the provided keyboard commands that are listed to the right of the
respective menu item :(for example, press <Ctrl> + <S> to execute “Save”).

Reload Options

The information shown in the Java tool can be reloaded in different ways.
e Via <F5> key on the used keyboard

e Via Edit > Reload in the menu bar

* VVia “Reload” Symbol in the symbol bar

Context Function

The Java tool offers several context functions that support a user-friendly and
effective operation of the tool. The context functions are described in the
respective chapters.

To execute a context function, use the right mouse button on the corresponding
field and select the desired function.

Sorting Function

Lists and tables in the Java tool offer a sorting function for fast and smooth
search.

1. For ascending sort status, use the left mouse button once to click into the
header of the column you want to sort.

The sort status is indicated by an arrow that points upwards.

2. For descending sort, use the left mouse button twice to click on the header of
the column that you want to sort. The sort is displayed by an arrow that points
downwards.

3. To cancel the sort, use the left mouse button once or twice to click on the
header of the column that is sorted until the displayed arrow disappears.
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Filter Function

Lists and tables in the Java tool offer a filter function that enables a fast and
smooth search.

1. To activate a filter, use the right-mouse button to click on the header of the
column you want to filter and select Set Filter.

2. Write the word or part of a word you want to filter directly into the header.
The filter results are shown immediately.

3. To delete a filter, use the right mouse button to click on the header of the
column you want to filter and select “Clear Filter.”

NOTE: An asterix in the header indicates an active filter.

The filter function is based on the functional principle of common Web
search engines.

Configuration in the Java Tool (Off-line Configuration)

You can only change configuration and system settings via Java tool in off-line
mode without a direct connection between ServSwitch DKM FX and Java tool.

To activate a configuration in the ServSwitch DKM FX:
1. Select “File > Upload to” in the menu bar.

2. Enter the IP address of the ServSwitch DKM FX (see Section 4.2.3) and the
name and password of the user authorization and select the storage location
of the new configuration (default or config01-08) in the menu “Select
Configuration.”

3. Select “Matrix > Connect” in the menu bar and enter the IP address of the
matrix and the name and password for user authorization.

4. Select “Administration > Activate Configuration” in the task area and select the
storage location that you selected above.

5. Use the “Activate” button to open the selected configuration within the matrix.
The connection and the open tab will close, and the matrix will restart.

NOTE: During the activation of a configuration, the matrix is temporarily not
available.
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On-line Configuration

Configurations and system settings can be also edited via the Java tool in On-line
mode with an active connection between matrix and Java tool.
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Figure 4-7. Menu System—System Data.
To edit a configuration in online mode, proceed as follows:

1. Select the menu item “Matrix > Activate Online Configuration Mode.” This
setting will also be shown in the lower part of the working area.

2. Make any edits at the configuration and system settings and confirm by
pressing the “Apply” button. The changes will be applied immediately.

3. To deactivate the On-line mode, select the menu item “Matrix > Deactivate
Online Configuration Mode"” in the menu bar.

Options menu
You can adapt and customize the Java tool by editing various default settings.
To activate or change the default settings, proceed as follows:

Select “Extras > Options” in the menu bar. The tab Default Settings will open.
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The default settings parameters are:

Table 4-8. Default settings.

Option Description
IP/Hostname Default IP address of the matrix required for connection.
User Default user name used for connection.

Configuration Directory Default directory for configuration files.
Firmware Directory Default directory for update files.

Status Directory Default directory for the firmware status.
Import/Export Directory Default directory for import and export files.

Presets Directory Default directory for macro files.

To set various font sizes for the Java tool, proceed as follows:
1. Select “Extras > Options” in the menu bar.

2. Open the tab Font.

3. Select the desired font size (normal or large).

Report

The Java tool is equipped with a report function that shows the current switching
status and all relevant parts of the matrix configuration in a PDF file.

To create a report, proceed as follows:
1. Select “File > Report...” in the menu bar. A selection assistant will be opened.

2. Select those contents that should be included in the report (Matrix View,
EXT Units, CPU Devices, CON Devices, and Users) and confirm with the
“Next >" button.

3. Select the preferred location for storage of the report and confirm with the
“Finish” button.

The report will be created as a PDF file.
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Figure 4-8. Menu File > Report.

NOTE: The report function can be used in both On-line or Off-line mode of the
Java tool.

4.2.3 Control via Serial Interface

RS232

Figure 4-9. RS-232 icon.

The ServSwitch DKM FX operating system offers various functions for operation
via serial interface. There are telegrams for switching single or all connections
available, both unidirectional and bidirectional. There are also telegrams for an

overall definition of the total switching status and for saving and loading such
switching states.
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The ServSwitch DKM FX has an option that provides an echo of all affected
switching operations via serial interface or network interface. It enables you to
track the current configurations of the matrix at any time so you can update your
own applications.

You can also switch ServSwitch DKM FX clones as slaves (stacking) in parallel via a
serial network interface.

4.3 Assignment
The ServSwitch DKM FX enables you to create a console-specific or a CPU-specific
assignment.

® You can assign virtual CPUs to real CPUs.
* You can assign real consoles to virtual consoles.

4.3.1 Virtual CPU

Switch several consoles to the same CPU. If there are several consoles connected
to a virtual CPU that is assigned to a real CPU, you will only have to change the
real CPU once and all the consoles will receive the video signal of the new CPU.

You can access the menu via OSD or Java.
‘m

0sD

)
=
JA

/f,

Figure 4-10. OSD and Java icons.
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OSD

Select “Assignments > Virtual CPU Devices” in the main menu.

=] = i} 2] = ||

01005 MAC B4 ANA g1087 CPU B7
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02 VCPU_0B2002 01006 CPU_B8 81001 NAC 02 DAD_HID
01003 MAC_B3_ANA_HID
01002 WIN/UBU_85_USB
01000 WIN/UBU_B6_USB

Figure 4-11. Menu Assignments — Virtual CPU Devices.
For an assignment, proceed as follows:

1. Select the virtual CPU in the list Virtual Devices that has to be assigned to a real
CPU.

2. Press the “Edit” button.

3. Select the CPU in the list Real Devices that has to be assigned to the selected
virtual CPU.

4. Press the “OK" button to confirm the assignment.
The assignment will be done.

NOTE: Only one virtual CPU can be assigned to a real CPU.
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Java Tool

Select “Assignment > Virtual CPU Devices” in the task area.
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Figure 4-12. Menu assignment—Virtual CPU devices screen.
For an assignment, proceed as follows:
1. Select a virtual CPU in the "Virtual CPU" list.
2. Double-click in the “Real CPU" column to get a list of all available real CPUs.
3. Select a real CPU.

You can select between the following buttons:
Table 4-9. Selection buttons.

Button Function

Send Send assignments to the matrix
Reload  Reload changes

NOTE: By activating the “Auto Send” function in the left lower corner of the
working area, switching operations will occur immediately without
pressing the “Send” button to confirm.
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The selection boxes in the Real CPU column contain a filter function for an easy
selection of single consoles from a larger pool of consoles.

The Java tool also offers the possibility to go directly from the Assignment menu
to the Definition menu to check specific settings for the respective console or
CPU.

Use the right-mouse button to select the respective console or CPU and select
“Open CON Device” or “Open CPU Device.”

4.3.2 Virtual Console

You can assign real consoles to virtual consoles in this menu.

Using this function, you can change access permissions of the virtual console and
apply them to all assigned real consoles, too.

You can access the menu via OSD or Java.
- W

25

osD [JNUAVA

Figure 4-13. OSD and Java icons.
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OSD

Select “Assignments > Virtual CON Devices” in the main menu.

83006 _CON 016123491 84000 VCON_ 84000 94000 VCON 04008
03000 N_010 0 04001 VCON_B4001
03002 CON_010125349 04000 VCON_04008 04002 VCON_D4LpO2
03001 CON_010125524
03004 012956

03005 CON_010129653 04081 VCON_04001
03003 CON_010148887

Figure 4-14. Menu Assignments — Virtual CON Devices.
For an assignment, proceed as follows:

1. From the “Virtual Devices” list, select the real console that has to be assigned
to a virtual CPU.

2. Press the “Edit” button.

3. Select the virtual console in the list Virtual Devices that has to be assigned to
the selected real console.

4. Press the “OK" button to confirm the assignment.

NOTE: A virtual console can be assigned to more than one real console.
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Java Tool

Select “Assignment > Real to Virtual Console” in the task area.
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Figure 4-15. Menu Assignment—YVirtual Console Devices screen.

To place an assignment, proceed as follows:
1. Select the required real console in the “Real Console” table.

2. Double-click in the “Virtual Console” column to get a list of all available virtual
consoles.

3. Select the required virtual console.
You can select between the following buttons:
Table 4-10. Send and Cancel
selection buttons.

Button Function

Send Send assignments to the matrix

Cancel  Reject changes
NOTE: If you activate the Auto Send function in the left lower corner of the

working area, switching operations will occur automatically without
pressing the Send button to confirm.
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The selection boxes in the Virtual Console column contain a filter function so you
can easily select a single CPU from a larger pool of CPUs (see Section 4.2.2).

4.4 System Settings
You can configure the following system settings at the ServSwitch DKM FX.

NOTE: Only users with administrator rights can configure the system settings.

4.4.1 System Data
The system configuration is set in this menu.

You can access the menu via OSD and Java:

Figure 4-16. OSD and Java icons.
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Select from the following settings:

Table 4-11. System data settings.

Field Selection Description
Device Text Enter the device name of the matrix (default: SWITCH 01)

Enter the name of the configuration that is used to save the current
Name Text

settings (default: Standard)

Additional text field to describe the configuration (default: Factory

Info Text settings)
If the matrix is defined as a slave in the OSD, the user will lose control
Activated automatically. Use the keyboard command <Shift><Shift><s><o>to
recover control. The OSD will open again in the matrix defined as
Sub matrix slave.
Deactivated Function not active (default)
. Save the current configuration of the matrix in the flash memory
Activated -
Auto Save periodically.
Deactivated Function not active (default)
Send all performed switching commands in the matrix as an echo via
serial interface.
Enable COM AetvaEs : : ; : : :
NOTE: Enable this function when using media control via the serial
echo interface.
Deactivated Function not active (default)
Send all performed switching commands in the matrix as an echo via
LAN connection.
Activated
Ensble LAN NOTE: Enable this function when using media control via the serial
echo interface.
Deactivated Function not active (default)
. Synchronize the slave matrix according to the switch status of the
Activated )
Slave matrix master matrix.
Deactivated Function not active (default)
Master IP Numerical value Set the network address of the master matrix (default value:
address 000.000.000.000)
Hor. Mouse . .
1-9 Adjust the horizontal mouse speed, 1= slow, 9 = fast (default value: 5)
Speed 1/x
Ver. Mouse . :
1-9 Adjust the vertical mouse speed, 1= slow, 9 = fast (default value: 5)
Speed 1/x
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Table 4-11 (continued). System data settings.

Field Selection Description
Double click . . .
time 100-800 ms Adjusts the time slot for a double click (default value: 200 ms)
Keyboard Region Set the OSD keyboard layout according to the used keyboard;
layout 9 Default: English (US)
Additional text field to describe the configuration (default: Factory
Info Text .
settings)
If the matrix is defined as a slave in the OSD, the user will lose control
Activated automatically. Use the keyboard command <Shift><Shift><s><o>to
recover control. The OSD will open again in the matrix defined as
Sub matrix slave.
Deactivated Function not active (default)
. Save the current configuration of the matrix in the flash memory
Activated o
Auto Save periodically.
Deactivated Function not active (default)
OSD

Select Configuration > System in the main menu.

Figure 4-17. Menu Configuration—System screen.
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Table 4-12. Cancel and Save
selection buttons.

Button Function

Cancel  Reject changes

Save Save changes
Java Tool
|
£2e_ ot e Exvas 3

Nl O X8Rk ## > * B3 u &

T . System-System Data

.
e o) Soow ety
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Access Ceacraten 1f curart marm comtouraics
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Enable COM Echo
Enable LAN Echo v
e ~
‘Siarve Matrix

Figure 4-18. Menu System—System Data.

4.4.2 Automatic ID
From this menu, you can automatically create CPU and CON devices’ settings by
connecting a new extender unit.

You can access the menu via OSD or Java:

—

0SD JAV/

Figure 4-19. OSD and Java icons.
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You can select between the following settings:

Table 4-13. Automatic ID settings.

Field Selection Description
Activated Automatically creates a new CPU or CON device if new extender units
Enable Auto are connected (default)
Config
Deactivated Function not active
:I))e\'jieczl cPu Numerical value Initial value of the automatic ID for real CPUs (default value: 1000)
ID Virtual . " . .
) Numerical value Initial value of the automatic ID for virtual CPUs (default value: 2000)
CPU Device
:IDDe\F/{if:ael CON Numerical value Initial value of the automatic ID for real CONs (default value: 3000)
ID Virtual . " . .
) Numerical value Initial value of the automatic ID for virtual CONSs (default value: 4000)
CON Device
OSD

Select Configuration > System in the main menu.

Figure 4-20. Menu Configuration—System screen.
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Table 4-14. Cancel and Save
selection buttons.

Button Function

Cancel  Reject changes

Save Save changes

Java Tool
Select "System > Automatic ID” in the task area.
Iﬁl
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Figure 4-21. Menu System—Automatic ID screen.

4.4.3 Access
The access configuration is set in this menu.

You have the following possibilities to access the menu:

m |77
0SD JAVA

Figure 4-22. OSD and Java icons.
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Table 4-15. Access settings.

Field Selection Description
The user has to log in with a user name and a password code to enter
Force User Activated OSD. Thereafter, the user remains logged in until he explicitly logs out
Login or an auto logout is effected.
Deactivated Function not active (default)
CPU access is restricted according to the permissions in the ACL
(Access Control List).
Enable User ez e User login is required.
ACL o ) ) )
e Switching by keyboard hotkeys requires a prior login.
Deactivated Function not active (default)
——— CPU access is restricted according to the permissions of the respective
Enable Access Control List (ACL). No login is required.
Console ACL
deactivated Function not active (default)
Enable new  activated Newly-created users automatically receive access to all CPUs
user deactivated Function not active (default)
Enable new  activated Newly-created CON devices automatically receive access to all CPUs
CON deactivated Function not active (default)
. Upon opening the OSD, the console will automatically disconnect from
activated
Auto the current CPU.
Disconnect
deactivated Function not active (default)
0osb Period of inactivity after which OSD will close automatically.
: 0-999 seconds
Timeout

e Select 0 seconds, for no timeout (default: 0 seconds)

Auto Logout

0-999 seconds

Period of inactivity of a logged-in user after which he will be
automatically logged out at the console.

There might be a disconnect because of the logout, depending on the
defined rights in each CON and user ACL.

e Select 0 minutes, for an automatic use logout when leaving OSD.

e Using the setting -1 allows the user to be logged in permanently,
until a manual logout is executed.

e The timer is not active as long as the OSD is open.
(default: 0 minutes)
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OSD

Select “Configuration > Access” in the main menu.

Figure 4-23. Menu Configuration Access screen.

You can select between the following buttons:

Table 4-16. Cancel and Save
selection buttons.

Button Function

Cancel  Reject changes

Save Save changes
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Java Tool

Select “System > Access” in the task area.
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Figure 4-24. Menu System—Access screen.

4.4.4 Switch
The configuration of the switching parameters is set in this menu.

You have the following possibilities to access the menu:

Figure 4-25. OSD and Java icons.
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You can select between the following settings:

Table 4-17. Switch settings.

Field Selection Description
The user can switch to any CPU as an observer, even to ones that are
already assigned to another user (observer without keyboard/mouse
access).
. Activated . .
Video o NOTE: Switch with the <Space> key, not the <Enter> key.
Sharing
® The operator will not be informed if further users connect as an
observer to the CPU that is connected to his console.
Deactivated Function not active (default)
The user can connect to every single CPU as an operator, even to ones
that are related to another user.
Force At ® NOTE: The previous user is set to video-only status.
Connect )
e To share K/M control, Force Connect must be activated.
Deactivated Function not active (default)
Extension of Force Connect: If the user connects to a CPU as an
; operator that is already related to another user, the connection to the
Force Activated previous user will be completely disconnected.
Disconnect NOTE: To share K/M control, Force Connect must be deactivated.
Deactivated Function not active (default)
If a console is not connected to a CPU, you can establish an automatic
Activated connection to the next available CPU by pressing any key or mouse
CPU Auto b
utton.
Connect
Deactivated Function not active (default)
CPU 0-999 Period of inactivity after which a console will automatically disconnect
Timeout minutes from its current CPU. (default value = O minutes)
Activated Activate request of K/M control by keyboard event (key will be lost)
Keyboard
Connect ) ) .
Deactivated Function not active (default)
Activated Activate request of K/M control by mouse event
Mouse
Connect . . .
Deactivated Function not active (default)
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Table 4-17 (continued). Switch settings.

Field Selection Description

Period of inactivity of a connected console after which K/M control
can be requested by other consoles connected to the CPU.
) 0-999 o NOTE: Set “0” for an immediate transfer in real time.
Release Time seconds
® Only one console can have keyboard and mouse control at the same
time. The other consoles that are connected to the same CPU have a
video-only status (default value: 10 seconds)

NOTE: If the “Keyboard Connect” and/or “Mouse Connect” options are activated,
the Release Time condition must be met until a new user gains control.

OsD

Select “Configuration > Switch” in the main menu.

Figure 4-26. Menu configuration—System.
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Table 4-18. Cancel and Save
selection buttons.

Button Function

Cancel  Reject changes

Save Save changes

Java Tool
Select “System > Switch” in the task area.
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Figure 4-27. Menu system—switch.
4.4.5 Network
The network configuration is set in this menu.

You have the following possibilities to access the menu:

—

0SD JAV/

Figure 4-28. OSD and Java icons.
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Table 4-19. Network settings.

Field Selection Description
Activated (T:e]c neli\)/vork settings are automatically supplied by a DNS server
DHCP ctau
Deactivated Function not active
IP address Byte Input of the IP address in the form “192.168.1.1,” if DHCP is not active
Subnet mask  Byte Input of the subnet mask in the form “255.255.255.0,” if DHCP is not
v active (default 255.255.255.0)
Input of the subnet mask in the form “192.168.1.1,” if DHCP is not
Gateway Byte .
active
. LAN interface at the switch activated for access via Java tool
Activated )
APl service (API service port 5555)
Deactivated Function not active
Activated FTP server for tranmission of configuration files activated.
FTP server
Deactivated Function not active
Activated HTTP server activated (not yet implemented)
HTTP server
Deactivated Function not active
Activated Telnet server activated (not yet implemented)
Telnet server
Deactivated Function not active
Activated SNMP agent for matrix monitoring active (not yet implemented)
SNMP agent
Deactivated Function not active
Activated Syslog server for status request is active
Syslog
Deactivated Function not active
Syslog server  Byte Input of the OP address of the Syslog servers in the form “192.168.1.1"
DEB Activate debug messages in Trace (default: Yes)
INF Activate information messages in Trace (default: Yes)
Trace NOT Activate notification messages in Trace (default: Yes)
WAR Activate warning messages in Trace (default: Yes)
ERR Activate error messages in Trace (default: Yes)
DEB Activate debug messages in Syslog (default: Yes)
INF Activate information messages in Syslog (default: Yes)
5 NOT Activate notification messages in Syslog (default: Yes)
WAR Activate warning messages in Syslog (default: Yes)
ERR Activate error messages in Syslog (default: Yes)
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NOTE: To activate the modified network parameters, restart the ServSwitch DKM.

CAUTION: Consult your system administrator before modifying the network
parameters. Otherwise, unexpected results and failures can occur in
combination with the network.

OsD

Select "Configuration > Network” in the main menu.

x_l

Network Interface

255 1255 4255 4000 |

Figure 4-29. Menu Configuration—Network screen.

Table 4-20. Cancel and Save
selection buttons.

Button Function

Cancel  Reject changes

Save Save changes
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Java Tool

Select “System > Network” in the task area.
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Figure 4-30. Menu system—network.
4.4.6 Date and Time
Date and Time are set in this menu.

You can access the menu via OSD:

0OsD

Figure 4-31. OSD icon.
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Table 4-21. Date and time settings.

Field Selection Description
Month 1-12 Enter month
Date 1-31 Enter date

Year 1-99 Enter year

Day 1—7 5:;:; day of the
Hours 0-23 Enter hour
Minutes 0-59 Enter minute
Seconds 0-59 Enter second

OSD

Select “Configuration > Date+Time" in the main menu.

Figure 4-32. Menu Configuration—Date and Time screen.
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You can select between the following buttons:

Table 4-22. Cancel and Save
selection buttons.

Button Function

Cancel  Reject changes

Save Save changes

4.5 User Settings
You have the possibility to configure the following user settings:

4.5.1 User Data
New users and their user settings and permissions are set in this menu.

You have the following possibilities to access the menu:

Figure 4-33. OSD and Java icons.
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You can select between the following settings:

Table 4-23. User data settings.

Field Selection Description
Name Text User name (case-sensitive)
Password Text User password (case-sensitive)
Repeat Text Repeat user password (case-sensitive)
Password P P
Activated Access permission via HTTP
HTTP
Deactivated Function not active (default)
. Access permission via FTP. This setting is necessary for file access from
Activated
TP the Java tool or any Web browser.
Deactivated Function not active (default)
Activated Access permission via Telnet
Telnet access
Deactivated Function not active (default)
e User has rights
activated
Power User e Permission for crosspoint operations
deactivated Function not active (default)
¢ Permission for system configuration and all switching operations
activated e User has administrator rights
Super User ) o . . . )
e This setting is required for an online connection with the Java tool
deactivated Function not active (default)
¢ Permission for system configuration and all switching operations
activated e User has administrator rights
o e This setting is required for an online connection to the Java tool
Administrator
deactivated Function not active (default)
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OSD

Select “Configuration > User” in the main menu.
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Figure 4-34. Menu Configuration—User screen.

Table 4-24. OSD settings.

Button Function

New Create a new user

Edit Edit an existing user
Delete Delete an existing user
Cancel Reject changes

Save Save changes
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Java Tool

Select “User > User Data” in the task area.
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Figure 4-35. Menu User—User Data screen.

Table 4-25. OSD settings.

Button Function

New Create a new user

Delete Delete an existing user
Apply Create a new user account
Cancel Reject changes

To configure user access rights for CPUs, proceed as follows:

1. Select a user in the User Data list.

2. By using the right mouse button once on a CPU in one of the respective access
lists (Full Access, Video Access, and No Access), two lists for selection will

appear in which the respective CPU can be moved and the access rights can be
changed.

3. Confirm the configuration by pressing the “Apply” button.
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To create a new user, proceed as follows:

1. Press the “New" button.

2. Select a template of an existing user if applicable (choose template).
3. Press the “OK" button.

4. Set a user name.

5. Set password.

6. Set general access permissions.

7. Set user permissions for CPU access (paste function).

8. Set user favorites for OSD access.

9. Press the “Apply” button to save the new user settings.

You can select between the following keyboard commands:

Table 4-26. Keyboard commands.

Function Keyboard Command
Add CPU to Full Access list <F>
Add CPU to Video Access list <V>
Add CPU to No Access list <N>

4.5.2 Favorites List Users

Individual favorites lists of CPUs that have to be switched frequently can be
created for different users in this menu. A Favorites list can contain up to eight
sdifferent CPUs.

The switching of the favorites is done via hotkeys using the keyboard.
You can access the menu in two ways: via OSD or Java.
-

25

0sD AVA
Figure 4-36. OSD and Java tool icons.
OosD

Select "Assignments > User Favorites” in the main menu.
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Figure 4-37. Menu Assignments — User Favorites.
To create a Favorites list for you own user, proceed as follows:

1. Select CPUs from the list CPU Devices that have to be moved to the Favorites
list. By pressing the key <a>, a CPU device will be moved to the Favorites list
and it will be removed by pressing <r>.

2. To change the order of the CPU devices within the Favorites list, press the <+>
and <-> keys.

3. Press the “Save” button to save the settings.
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Java Tool

Select the respective user in the working area of the User menu for the Favorites
list and open the Favorites tab.

Fde ot Man Exvas 2
1BH O XPR FF 2 B &

[ somngassassaes s € |
ey . Definition - User
"D tame |
= © N ©
Jrr—— . -
Passwors
Assagnment *
o pow aom
System
| £ Access Control | Favostes | uacres
Detmition
EXT sty O [Hame s 0 lame
CPUDences
COH Coracas o0
user ) 02
03
[
05
oe
o7
08

Figure 4-38. Definition — User.
To create a favorite list for any user, proceed as follows:

1. Select the CPUs in the CPUs Available list to add to the Favorites list (CPU
assigned). Press the <Ctrl> key to mark more than one CPU device.

2. Press the “>" button to move the marked CPU devices to the Favorites list.
Press the >> button, to move the first eight CPU devices from the CPU
Available list to the Favorites list (CPU assigned).

3. To change the order of marked CPU devices within the Favorites list, press the
<+> and <-> keys.

4. To remove marked CPU devices from the Favorites list, press the “<” button.
Press the “<<" button to remove all CPU devices from the Favorites list.
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4.5.3 User Macros

In this menu, you can create macro commands for switching, disconnection, or
user administration. The macro commands are created for each user separately.

A macro can execute up to 16 switching commands successively.

You will use hotkeys and the function keys <F1>-<F16> to execute the

macros.

NOTE: To execute user macros, the user has to be logged in at the matrix.

You can select between the following settings:

Field

Function (01-06)

P1

P2

Selection

Connect,
(P1 = CON, P2 = CPU)

Connect Video,
(P1 =CON, P2 =CPU)

Disconnect (P1=CON)
Logout User

Set Real CPU
(P1 =VCPU, P2 = RCPU)

Set Virtual CON
(P1 = RCON, P2 = VCON)

Push (P1 = CON)

Push Video (P1 = CON)

Get (P1 = CON)

CON or CPU Device

CPU or CON Device

Table 4-27. Settings.

Description

Set bidirectional connection from console P1 to CPU P2.

Set video connection from console P1 to CPU P2.

Disconnect console P1.

Logout current user.

Assign a virtual CPU to a real CPU.

Assign a real console to a virtual console.

The individual KVM connection is forwarded to console P1 and is
changed to a video-only connection.

The video signal of the current connection (KVM or video only) is
forwarded to console P1. The individual connection remains
unchanged (KVM or video only).

The individual console gets a video-only connection to the CPU that os
currently connected to console P1. The connection of console P1
remains unchanged (KVM or video only).

Name of CON or CPU device.

Name of CON or CPU device.
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You can access the menu in two ways: OSD or Java.

Figure 4-39. OSD and Java icons.
OsD

Select the user that you want to create a user macro for from the “Configuration
> User Macros” in the main menu.
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Actual CON device

Disconnect CON

Figure 4-40. Menu Configuration - User Macros.
To create a macro for the selected user, proceed as follows:
1. Select the key for which a macro has to be created. Choose from 1-16.

2. Select the respective place on the list (1-16) of the key that has to be set with a
macro key.

3. Select the marked place on the list a macro command in the “Macro Data”
field.
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4. Set the necessary parameters P1 and P2 (for example, CON Devices or CPU
Devices) for the selected macro command.

5. Confirm your inputs by pressing the <Enter> key and repeat the process for
further macro commands, if necessary.

Java-Tool

In the working area of menu “Definition > User,” select the user for which macros
have to be created and open the tab Macros.
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Figure 4-41. Menu Definition - User
To create a macro for the selected user, proceed as follows:
1. Select the Key (1-16) for which a macro has to be created.

2. Select in the Function the commands that should be part of the macro. Open
the selection list by double-clicking on the empty fields.

3. Select the respective parameters for the macro functions (for example,
corresponding consoles and CPUs) in the P1 and P2 columns.

4. Confirm your inputs by pressing the “Apply” button.
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For an efficient macro configuration, the following context functions are available:

Via right-click on the tab Macros, macros can be assigned to other users by using
the “Assign Macros to ...” function and can be copied from other users by using
the “Copy Macros from ...."” function.

Via right click on the macro list, you can copy macros of the selected key into the
cache by using the “Copy Key Macros” function. You can paste the macros from
the cache into a key by using the “Paste Key Macros” function and you can reset
all macros of the selected key by using the function “Key Macros” function.

4.6 Extender Settings

All extender units are managed in this menu. This also contains the creation of
new extender units and the deletion of existing extender units.

The extender unit describes the connection of a physical extender to the matrix.
Every extender board with a direct cable connection to the matrix is recognized
as an extender unit. Dual-head KVM extenders will be recognized as two
independent extender units.

NOTE: KVM extenders automatically create extender units inside the matrix.

To access the menu, use OSD or Java:

0sD

Figure 4-42. OSD and Java icons.

Table 4-28. OSD settings.

Field Selection Description

Numerical value of the extender ID (KVM extenders: ID is

D Text provided by extender unit [serial no.] and cannot be changed)
Name Text Name of the extender unit

} Activated Create an extender unit with a fixed port assignment (default)
Fixed Deactivated Function not active (default)

1-288 (depending

) Port number of the extender unit
on the matrix)

Port
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OSD

Select “Configuration > EXT Units” in the main menu.
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Figure 4-43. Menu Configuration—EXT Units screen.
You can select between the following buttons:

Table 4-29. Extender (EXT) units settings.

Button Function

New Create an extender unit

Edit Edit an existing extender unit
Delete Delete an existing extender unit
Cancel Reject changes

Save Save changes

The settings for the tab OSD Data are described in Section 4.8.2.

Java Tool

Select “Definition > EXT Units” in the task area.
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Figure 4-44. Menu Definition—EXT Units screen.

You can select between the following buttons:

Table 4-30. OSD settings.

Button Function

New Create a new extender unit

Delete Delete an existing unit

Apply Confirm changes of an extender unit
Cancel Reject changes

1. To create a new extender unit, press the button “New.”

2. Select whether a template of an existing extender unit (“Choose extender as
template”), a template of an predefined extender type (“Choose extender
type”) or no template (“None"”) should be used.

3. Press the “OK" button.
4. Set all relevant parameters for the extender unit.

5. Press the “"Apply” button to save the new extender unit.
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CAUTION: Created extender units are always set as fixed-port extenders. These
configurations are necessary, if you want to switch, for example, USB
2.0 connections via the matrix.

4.6.1 Creating Flex-Port Extender Units

Extenders with ID function are automatically recognized by the system and cannot
be created manually. They were used at “Flex-Ports” at the matrix.

NOTE: The connection of fixed-port extender unit (for example, USB 2.0) to a
Flex-Port can cause unintended results.

4.6.2 Creating Fixed-Port Extender Units
To create a fixed-port extender unit (for example, USB 2.0), proceed as follows:

1. Press the “New"” button.

2. Select whether a template for a USB 2.0 CON unit (USB CON Unit) or USB 2.0
CPU unit (USB CPU Unit) should be used.

3. Press the “OK" button.

4. Determine a port at the matrix that should be used with the USB 2.0 extender
unit (Fixed Port). As an option, the name of the USB 2.0 extender unit can be
changed (Name).

5. Press the “Apply” button to save the new extender unit.

NOTE: Created extender units are always set as fixed-port extenders. These
configurations are necessary, if you want to switch, for example, USB 2.0
connections via the matrix.

4.6.3 Deleting Flex-Port Extender Units
Deleting Flex-Port extender units connected to the matrix is not possible.

4.6.4 Deleting Fixed-Port Extender Units
To delete a fixed-port extender unit (for example, USB 2.0), proceed as follows:

1. Verify that the fixed-port extender unit to be deleted is currently not assigned
to a device.

2. Select the fixed-port extender unit to be deleted in the selection list on the left
side of the menu EXT Units and confirm with the key <Enter>.

3. Press the “Delete” button.

4. Press the "OK" button to confirm the deletion.
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To make a fixed port available again for Flex-Port extender units after deleting a
fixed-port extender unit, restart the matrix.

4.7 CPU Settings
New CPU devices are configured in this menu including their assignment to
extenders.

The assignment helps to describe and switch more complex computer
configurations (for example, Quad-Head with USB 2.0) in the matrix.

You can access the menu via the OSD or Java icon:

Figure 4-45. OSD and Java icons.
You can select between the following settings:

Table 4-31. CPU settings.

Field Selection Description
ID Text ID of the CPU unit (see Section 4.4.2)
Name Text Name of the CPU device

Activated Create new CPU device as a virtual one
Virtual Device

Deactivated Function not active (default)

Activated Allows switching to the respective CPU device in Private Mode.
Allow Private

Deactivated Function not active (default)

Activated Force switching to the respective CPU only in Private Mode.
Force Private

Deactivated Function not active (default)

Activated Force showing a red frame when switching to the respective
Fix Frame CPU.

Deactivated Function not active (default)
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OsD

Select “Configuration > CPU Units” in the main menu.
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Figure 4-46. Menu Configuration—CPU Devices screen.

You can select between the following buttons:
Table 4-32. CPU unit buttons.

Button Function

New R. Create a new real CPU unit

New V. Create a new virtual CPU unit
Edit Edit an existing CPU device
Delete Delete an existing CPU device
Cancel Reject changes

Save Save changes
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Java Tool

Select “Definition > CPU Devices” in the task area.
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Figure 4-47. Menu Definition—CPU Devices screen.

You can select between the following buttons:

Table 4-33. CPU devices buttons.

Button Function

New Create a new CPU device

Delete Delete a new CPU device

Apply Confirm a created CPU device
Cancel Reject changes

> Assign selected extender units

>> Assign all available extender units
< Remove the selected extender units
<< Remove all extender units
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You can select between the following keyboard commands:
Table 4-34. Keyboard commands.

Function Keyboard Command
Change assignment number of the extender unit upwards <+>
Change assignment number of the extender unit downwards <>

To create a new CPU device, proceed as follows:
1. Press the “New" button.

2. Select whether a real CPU (“Create a real CPU") or a virtual CPU (“Create a
virtual CPU") should be created or a template of an existing CPU should be
used (“Choose template”).

NOTE: A template can be used only if there is at least one existing CPU device.
3. Press the “OK” button.

4. Determine all parameters that are relevant for the CPU.

5. To confirm the new CPU, press the “Apply” button.

To access a new CPU via matrix, an assignment of one or more CPU-type
extender units is required. Proceed as follows:

1. Select the new CPU in the CPU devices list.
2. Select one or more extenders in the Extender Available list.

3. Perform the assignment by pressing the “>"button. To assign all available
extenders to the CPU, press the “>>" button.

The assignments are displayed in the Extender Assigned list.
4. Confirm the assignment by pressing the “Apply” button.
To remove an extender assignment, proceed as follows:
1. Select a CPU in the CPU Devices list.
2. Select one or more extenders in the Extender Assigned list.

3. Remove the assignment with the “<” button. To remove all existing
assignments, press the “<<"” button.

4. Confirm the removal with the “Apply” button.
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4.8 Console Settings
You can perform the following console settings:

4.8.1 CON Devices

New CON devices are created in this menu including access rights and assignment
to extenders.

You can access the menu via OSD or Java:

Figure 4-48. OSD and Java icons.
You can select between the following settings:

Table 4-35. CON devices settings.

Field Selection Description
D Text ID of the CON unit (see Section 4.4.2)
Name Text Name of the CON device
Virtual Activated Create new CON device as a virtual one
device Deactivated Function not active (default)

Activated Allow user login at this CON device
Allow login

Deactivated Function not active

Activated Force user login at this CON device
Force login

Deactivated Function not active

If there is a loss of connection, the last picture shown will still be displayed
and is surrounded by an orange frame.

Activated
LOS frame If you switch to a CPU that does not have a video signal, a blank screen
will appear surrounded by an orange frame.
Deactivated Function not active (default)
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OSD

Select “Configuration > CON Devices” in the main menu.
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Figure 4-49. Menu Configuration—CON Devices screen.

You can select between the following buttons:

Table 4-36. CON devices buttons.

Button Function

New R. Create a real console
New V. Create a virtual console
Edit Edit an existing console
Delete Delete an existing console
Cancel Reject changes

Save Save changes
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Java Tool

Select “Definition > CON Devices” in the task area.
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Figure 4-50. Menu Configuration—CON Devices screen.

Table 4-37. Menu configuration—

CON devices buttons.

Button

Function

New

Open a new CON device

Delete

Delete a new CON device

Apply

Confirm a created CON device

Cancel

Reject changes

>

Assign selected extender units

>>

Assign all available extender units

<

Remove the selected extender units

<<

Remove all extender units
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You can select between the following keyboard commands:

Table 4-38. Keyboard commands.

Function Keyboard Command
Decrease assignment number of the extender unit ~ <+>

Increase assignment number of the extender unit <>

To create a new console, proceed as follows:
1. Press the “New" button.

2. Select “Create a real Console” to create a real console or a select “Create a
virtual Console” to create a virtual console, or select “Choose template” to use
the template of an existing console.

3. Press the “OK” button.
4. Determine all parameters that are relevant for the console.
5. To confirm a created console, press the “Apply” button.

To run a created CPU via matrix, you need to assign one or more CON units
(extenders). To place an assignment, proceed as follows:

1. Select the console in the CON devices list to be assigned to an extender.
2. Select the extender in the Extender Available list to be assigned to the CON.

3. Perform the assignment by pressing the “>" button. To assign all available
extenders to the console, press the “>>" button. The assignments are displayed
in the Extender Assigned list.

4. Confirm the assignment by pressing the “Apply” button.

To remove an extender assignment, proceed as follows:

1. Select the console in the CON devices to be modified list.

2. Select the extender(s) in the Extender assigned to be removed list.

3. Remove the assignment with the “<” button. To remove all existing
assignments, press the “<<"” button.

4. Confirm the changes by pressing the “Apply” button.
To configure the access rights of consoles to CPUs, proceed as follows:

1. Select a console in the CON devices list.
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2. Open the "CPU Access Control” tab.

3. Assign new access rights by using the right mouse button or the respective
keyboard commands (see below).

4. Confirm the configuration by pressing the “Apply” button.

NOTE: Once created, a new user automatically receives full access to all available
CPUs.

You can select between the following keyboard commands:

Table 4-39. Keyboard commands.

Function Keyboard Command

Add CPU to Full Access list <F>
Add CPU to Video Access list <V>

Add CPU to No Access list <N>

4.8.2 Mouse and Keyboard

From this menu, you can set the OSD configuration for mouse and keyboard. You
can access the menu via OSD or Java.

Figure 4-51. OSD and Java icons.

Table 4-40. Mouse and keyboard settings.

Field Selection Description
) Adjusts the horizontal mouse speed:
Horizontal speed 1/x =2 1=slow, 9 = fast (default value = 4)
. Adjusts the vertical mouse speed:
Vertical speed 1/x =9 1= slow, 9 = fast (default value = 5)
. Adjusts the time slot for a double-click
Double-click 100-800 (default value = 200 ms)
Set the OSD keyboard layout according
Keyboard layout Region to the keyboard you are using (default:

German [DE])

Variable or specific Resolution that is used when opening

Video mode resolution 0osD
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NOTE: The mouse and keyboard settings are console specific. You can set them
separately for every console.

OSD

Select “Configuration > EXT Units” in the main menu.

Figure 4-52. Menu Configuration—EXT Units screen.

You can select between the following buttons:
Table 4-41. Buttons.

Button Function
Cancel Reject changes
Save Save changes
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Java Tool

Select “Definition > EXT Units” in the task area.

NOTE: Set mouse and keyboard settings using the OSD Data tab.
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Figure 4-53. Menu Definition—EXT Units screen.
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4.8.3 Extender OSD

In this menu, the settings for the Extender OSD settings can be adjusted. These
are local settings that can be made individually for each console.

You can select between the following Extender OSD settings:

Table 4-42. Mouse and keyboard settings.

Field Selection

Activated
Enable extender OSD

Deactivated

Activated
Update connections

Deactivated
Display time 0-999 seconds
Horizontal position 10 pixels
Vertical position 10 pixels

Vertical position .
resolution

Variable or specific

Description
Enable Extender OSD (default: Yes)
Function not active

Update connection changes during
fade-in of Extender OSD (default: Yes)

Function not active
Duration of OSD fade-in (default: 10)

Horizontal OSD position (default: 2)
Vertical OSD position (default: 2)

Resolution that is used when opening
0osb

NOTE: When setting the horizontal OSD position, a prefixed minus describes the
orientation to the right edge of the monitor, for example, -2 means 2 x 10 = 20
pixels of distance to this edge. When setting a vertical position, a prefixed minus
describes an orientation to the bottom edge of the monitor.

If the “Update Connections” function is deactivated, the Extender OSD only

appears when switching via OSD.

You can access the menu in two ways: via OSD or Java.

‘m

0sD

Figure 4-54. OSD and Java icons.
OsD

Select “Configuration > EXT Units” in the main menu.
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Figure 4-55. Menu Configuration — EXT Units
To change the Extender OSD settings, proceed as follows:

1. Select the console extender in the list EXT-Units whose Extender OSD settings
has to be adjusted.

2. When confirming the selection by pressing the key <Enter>, the respective
console extender will be enabled for editing.
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Java Tool

Select “Definition > EXT Units” in the task area.
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Figure 4-56. Menu Definition — EXT Units.

To change the Extender OSD settings, proceed as follows:

1. Select the console extender in the list EXT-Units whose Extender OSD settings
have to be adjusted.

2. Open the “Extender OSD Data” tab.
3. Adjust the desired settings and confirm by pressing the “Apply” button.

4.8.4 Favorite List Consoles

Individual Favorites lists of CPUs that have to be switched frequently can be creat-
ed for different consoles in this menu. A Favorites list can contain up to 16 differ-
ent CPUs. You can switch favorites via hotkeys.

You can access the menu in two ways: via OSD or Java.

Figure 4-57. OSD and Java icons.
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OSD

Select “Assignments > CON Favorites” in the main menu.
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Figure 4-58. Menu Assignments — CON Favorites.
To create a Favorites list for your own console, proceed as follows:

1. Select successively the CPUs from the list CPU Devices that have to be moved to
the Favorites list. Press the <a> key to move a CPU device to the Favorites list.
Press the <r> key to remove a CPU device from the Favorites list.

2. To change the order of the CPU devices within the Favorites list, press the <+>
and <-> keys.

3. Press the “Save” button to save the settings.
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Java Tool

Select the respective user in the working area of the “CON Devices” menu for the
Favorites list and open the tab Favorites.

£oe Eot M Egas 2
B O X8R S 2 B W B
[ ¥ somngass2ss2ss 20 €3 |
s . Definition - CON Davices
"0 tame
Contrat o CON Assigoed
— 0 Hame CPU Connected
L) Virtsal Device
Assagnment * | o ABow User ACL
05
o= - Force Logn
0 LOS Frame
Detinition or
= | Estender Assignment | CPU Access Centol | Favortes | Macros |
EXT Units.
CPU Devics o9
CON Devces. 0 o Peame | L Nama
User = I3 o
12 %
13 Lt
u 04
05
" %
w o7
» o8
1 -
2
Fal
2
2

Figure 4-59. Menu Definition — CON Devices

To create a Favorites list for any console, proceed as follows:

1.

. Press the” >"

Select the CPUs in the CPU Available list that should be added to the Favorites
list (CPU assigned). To mark more than one CPU device at the same time, press
the <Ctrl> key.

button to move the marked CPU devices to the Favorites list. If
you press the “>>' button, the first eight CPU devices from the CPU Available
list will be moved to the Favorites list (CPU assigned).

. To change the order of marked CPU devices within the Favorites list, press the

<+> and <-> keys.

. To remove marked CPU devices from the Favorites list, press the “<” button. To

remove all CPU devices from the Favorites list, press the “<<" button.

4.8.5 Console Macros

In this menu, you can create macro commands for switching, disconnection, or
user administration. The macro commands are created for each console separately.
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A macro can execute up to 16 switching commands successively.

Execute the macros via “Hotkey” and the <F1>-<F16> function keys.

You can select between the following settings:

Table 4-43. Console macros settings.

Field

Selection

Description

Function (01-16)

Connect (P1 = CON, P2 = CPU)

Set bidirectional connection from Console P1
to CPU P2.

Connect video (P1 = CON, P2 = CPU)

Set video connection from Console P1 to CPU
P2.

Disconnect (P1 = CON)

Disconnect Console P1.

Logout user

Logout curent user.

Set Real CPU (P1 = VCPU, P2 = RCPU)

Assign a virtual CPU to a real CPU.

Set Virtual CON (P1 = RCON, P2= VCON)

Assign a real console to a virtual console.

Push (P1 = CON)

The KVM connection is forwarded to
Console P1 and is changed to a video-only
connection.

Push video (P1 = CON)

The video signal of the current connection
(KVM or video only) is forwarded to
Console P1. The connection remains
unchanged (KVM or video-only).

Get (P1 = CON)

The console gets a KVM connection to the
CPU that is currently connected to Console P1.
The connection of Console P1 is changed into
a video-only connection.

Get video (P1 = CON)

The console gets video-only connection to the
CPU that is currently connected to console P1.
The connection of Console P1 remains
unchanged (KVM or video-only).

P1

CON or CPU device

Name of CON or CPU device.

P2

CON or CPU device

Name of CON or CPU device.

You can access the menu in two ways: via OSD or Java.

Figure 4-60. OSD and Java icons.
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OsD

Via “Configuration > CON Macros” in the main menu, select the console for
which a console macro has to be created.

slowe  FotNext | S | F6:Find ES
CON devices CON Macros 5
F01

03000 CON 010125349 Connect 03000 CON_010125349 01001 CPU_B10135060
Disconnect 03000 _CON_ 010125349

Hacro . MacroOata

u mnu UIN ulul JL)
09000 CON 010125349 -

Figure 4-61. Menu Configuration - CON Macros

To create a macro for the selected console, proceed as follows:
1. Select the number key (1-16) for which a macro has to be created.

2. Select the respective place on the list (1-16) of the key that has to be set with a
macro key.

3. Select a macro command in the “Macro Data” field from the macro list.

4. Set the necessary parameters P1 and P2 (for example, CON Devices or CPU
Devices) for the selected macro command.

5. Confirm your inputs by pressing the <Enter> key and repeat the process for
further macro commands, if necessary.
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Java Tool

In the working area of the “Definition > CON Devices” menu, select the console
for which a console macro has to be created and open the “Macros” tab.
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Figure 4-62. Menu Definition - CON Devices
To create a macro for the selected console, proceed as follows:
1. Select the number key (1-16) for which a macro has to be created.

2. In the “Function” column, select the commands that should be part of the
macro. Open the selection list by double-clicking on the empty fields.

3. In the P1 and P2 columns, select the respective parameters for the macro
functions (for example, corresponding consoles and CPUs).

4. To confirm your inputs, press the “Apply” button.
For an efficient macro configuration, the following context functions are available:

® Right-click on the “Macros” tab to assign macros to other consoles by using the
“Assign Macros to ..."” function. Copy macros from other consoles by using the
“Copy Macros from ...." section.
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¢ Right-click on the macro list to copy macros of the selected key into the cache
by using the “Copy Key Macros” function. You can paste the macros from the
cache into a key by using the “Paste Key Macros” function and you can reset
all macros of the selected key by using the “Reset Key Macros” function.

4.9 Saving and Loading Configurations
You can set the following configurations:

4.9.1 Active Configuration
Use the OSD button to access the menu:
m
=
0sD
Figure 4-63. OSD button.
Select “Configuration > Save” in the main menu.

By selecting this menu item, the active configuration of the matrix is saved to the
permanent matrix memory. By default, the last configuration that has been saved
in this way will be restored after the matrix restarts.

NOTE: Changing or saving configurations blocks the matrix memory and freezes
all OSD menus for a few seconds. The switching connections are not
affected by this freeze.

If you select “Auto Save” within the system settings, it will automatically save the
configuration periodically.

4.9.2 Saving of Configurations (Internal)
In this menu, the current matrix configuration to predefined storage locations is
saved. However, it does not replace configuration buffering.

You can access the menu via OSD or Java:
[
0sD ;_.\ /2
Figure 4-64. OSD and Java icons.

In Active, the name and detailed information of the current configuration are
shown. This configuration can be saved now.
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In Default and File #1 to File #8, the name and the detailed information of the
respective saved configuration are shown. You can overwrite these storage
locations.

The storage location to be overwritten by the current configuration must be
selected explicitly.

Afterwards, the current configuration will be saved to this storage location and
will be immediately shown in the menu. The previously saved configuration that
was saved to this storage location is deleted.

OSD

You can save the created configuration within eight storage locations in the matrix
(File #1—File #8). You can also save a configuration as the default configuration.

1. Select “Configuration > Save As..."” in the main menu.

2. Select the required storage location “(File #1-File #8)" or “Default.”

Figure 4-65. Menu Configuration—Save As screen.
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Java Tool
To save the configuration into the internal matrix memory, proceed as follows:
1. Select “File > Upload to...” in the menu bar.

2. Enter the IP address of the matrix, your user name, and your password, and
and confirm the inputs. Press the “Next” button.

3. Select the storage location where the configuration will be saved (default or
config01-config08). Press the “OK" button to confirm.
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Figure 4-66. Menu File—Upload to screen.
4.9.3 Loading of Configurations (Internal)

Previously saved configurations are loaded in this menu.

You have the following possibilities to load configurations from files:

Figure 4-67. OSD and Java icons.

In Active, the currently loaded configuration is displayed.
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In addition to the default configuration, you can load up to eight further
configurations.

Select the configuration to be loaded from eight personalizable configurations and
the default settings.

The selected configuration will be immediately loaded and displayed in the menu
as "Active.” The previously active configuration is deleted.

OsD
1. Select "Configuration > Open” in the main menu.
2. Select the desired configuration.

3. Load the configuration by pressing the <Enter> key.

Figure 4-68. Menu Configuration—Open screen.

Java Tool

1. Select “Administration > Activate Configuration” during on-line mode in the
task area.

2. Select the required configuration.

3. Load the configuration by pressing the “Activate” button.
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Figure 4-69. Menu Administration—Activate Configuration on Switch screen.

4.9.4 Saving of Configurations (External)

You can save created configurations as a file, so that they will be independent of
the matrix and transportable.

You can access the menu via the Java icon:

Figure 4-70. Java icon.
1. Select “File > Save As” in the menu bar.

2. Select the directory of the configuration on your storage medium where it will
be saved.

NOTE: Configurations are always saved in a file with the ending “dtc.”
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Figure 4-71. Menu File—Save As screen.

4.9.5 Loading of Configurations (External)
Externally saved configurations are opened and activated in this menu.

You have the following possibilities to load configurations from files:

1. Select “File > Open..."” during off-line mode and select the storage location of
the configuration file that has to be opened.

2. Open the configuration by pressing the “Open” button.

3. Select "File > Upload to..."” in the menu bar to transfer the opened
configuration to the matrix. Enter the necessary parameters.

4. Select “"Matrix > Connect” in the menu bar to make a connection between the
matrix and the Java tool. Enter the necessary parameters.

5. Select "Administration > Activate Configuration” and select the configuration
to be activated.

6. Confirm the process with the “Activate” button.

The opened configuration is activated now and can be used.

Page 134 724-746-5500 | blackbox.com



Chapter 4: Configuration

£de EOt Mt Exras 2
IEH O X8R F&# £ DY W B

| % aamagraz 168100133 €3 |

3 Administration - Activate Configuration

Active Confiqurason: tame

Statu
Contrat
Admeistratos
Assgameat
Systom
Detestoa

G == TR == 1P Adaness

meservesumers neimut Desktop r
o =
L Loskin | (5 Bsbomexan !'] [ BRE-J3N | »
o -

Dotumente

- s
L i Boer
08 -
o7
)
o

Fae tiame

Flesof Type ) =

Opan Gancet

Figure 4-72. Menu File—Open screen.
410 Export and Import Options

The ServSwitch DKM FX offers the possibility to read out available configuration
lists (extender, CPUs, consoles and users) for exporting and importing again via
Java tool. You have the following possibilities to handle configuration lists.

Exported configuration lists are always saved in “.csv” format that allows off-line
editing with common spreadsheet applications.

You can export or import configuration lists via the Java icon:

Figure 4-73. Java icon.
4.10.1 Export Options
Configuration lists are exported in this menu. To export, proceed as follows:

1. Select “File > Export” in the menu bar.

2. After opening the menu, select the list to export (Extender, CPU, Console or
User).
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3. Select the storage location for the export file.

4. Confirm the export with the “Finish” button.
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Figure 4-74. Menu File—Export screen.
4.10.2 Import Options
Configuration lists are imported in this menu. To import, proceed as follows:

1. Select “File > Import” in the menu bar.

2. After opening the menu, select the list to import (Extender, CPU, Console or
User).

3. Select the directory of the list to import.
4. Confirm the import with the “Finish” button.
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Figure 4-75. Menu File—Import screen.

4.11 Firmware Update
4.11.1 Matrix Update
The firmware of the matrix can be updated in this menu.

To access the menu, use the Java icon:

Figure 4-76. Java icon.

NOTES:

To update the matrix, only use computers that are self-sustaining and not
integrated in the KVM extender/matrix setup.

Save your configuration externally before you will start the update.
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Preparation
Follow these steps to prepare for the matrix update:
1. Save the matrix configuration externally.

2. Open “Extras > Options” in the menu bar and insert the directory from which
the updated files should be sourced in the “Firmware Directory” setting.

3. Put all hot spare boards into the matrix.

CAUTION: Make sure that all USB 2.0 extenders are only connected to the
provided ports (fixed ports) before you start the matrix update. If you
don't, the stability of the update will be compromised.

Performing the Update
Prepare for the matrix update by following these steps:

1. Select “Administration > Update Matrix Firmware” in the task area.
All updateable components of the matrix will be automatically selected and
highlighted in green.
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Figure 4-77. Menu Administration — Update Matrix Firmware.
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2. To start the update, press the “Update” button in the popup window that
appears.

3. Restart the matrix after the update by pressing the “Restart matrix” button in
the lower part of the working area.

CAUTION: For a safe start of the matrix, we recommend a cold start (power
cycle).

4.11.2 Extender Update

In this menu, you can update the firmware of the extenders connected to the
matrix.

You can access the menu via the Java icon:

Figure 4-78. Java icon.
Preparation
Follow these steps to prepare for the extender update:

1. Save the matrix configuration externally.
Open “Extras > Options” in the menu bar and insert the directory from which

the update files should be standardly sourced in the “Firmware Directory” set-
ting.

2. Connect all hot spare extenders to the matrix.
Performing the Update in Standard Mode (parallel Update

1. Select “Administration > Update EXT Firmware"” in the task area. The standard
mode for the parallel update will be selected by default, and the “Upload
Firmware” tab will be open.
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Figure 4-79. Menu Administration — Update EXT Firmware.

2. Before the actual update process, all firmware files that have to be uploaded to
the respective 1/0 boards on the extenders will have to be updated. By select-
ing the update files, the 1/0 boards will be automatically chosen for the upload
in the “Selected” column and highlighted in green, but only if a newer firm-
ware version is selected.

3. Start the upload and distribution of the update files by pressing the “Upload”
button.

NOTE: By running the upload process, no update files will be installed. The update
process can be performed at a later time. If there are no selected 1/0O cards,
the upload of the update files will be performed in sequence.

4. A successful upload process will be confirmed by a popup. If you want to
directly start the actual update process, you will have to confirm this by press-
ing the “Yes” button. You will be immediately forwarded to the “Update
Firmware” tab.

NOTE: When updating an identical or an older firmware version as the version
that is currently installed, the “Force Update” option in the lower part of
the working area has to be enabled.
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Figure 4-80. Menu Administration — Update EXT Firmware.

5. Start the actual update process by pressing the “Update” button.

NOTE: Just before the update process, all affected I/0 boards will be set to Service
Mode and retrieved gradually after finishing the respective updates.
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Performing the Update in Expert Mode (Sequential Update)
Follow these steps to prepare for the extender update:

1. Select “Administration > Update EXT Firmware” and select “Expert Mode" in
the upper part of the working area. All updateable extenders will be
automatically selected and highlighted in green.
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Figure 4-81. Menu Administration — Update EXT Firmware.

2. Set the matrix into Service Mode upon request in the popup window or via
“Matrix > Activate Service Mode” in the menu bar.

During activation, all matrix functions are disabled on the 1/0 boards on which an
update is currently performed. An OSD picture indicates the activation of the
Service Mode and is displayed on all monitors that are connected to the matrix via
a CON device. Additionally, the Service Mode is indicated by a red tool icon in the
lower part of the working area.
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Flgure 4-82. OSD View Service Mode.

3. Start the update by pressing the “Update” button in the lower part of the
working area.

4. Quit Service Mode after updating upon request in the popup window or via
“Matrix > Deactivate Service Mode” in the task area.

5. In the Java tool via “Administration > Update EXT Firmware” in the “Expert
Mode Protocol” tab, verify that updates for all extenders have been installed
correctly.

4.12 License Management
In this menu, the matrix can be upgraded with new function bundles by using
license keys.

To get license keys to upgrade matrix functions, contact Black Box Technical
Support at 724-746-5500 or info@blackbox.com.

You can access the menu via the Java tool:

Figure 4-83. Java Tool.
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To activate a function bundle, follow these steps:

1. Select "Administration > License Management” in the task area.
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Figure 4-84. Menu Administration — License Management.

2. Enter your license key in the working area under “Activate Bundles” in the
“License Key” field.

3. To activate the license key, press the “Activate” button. The new functions will
be immediately enabled; a restart of the matrix will not be necessary.
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5. Operation
You can operate the ServSwitch DKM FX in three different ways:

1. Direct Switching

* via a keyboard connected to a CON port and the hotkeys

* by a macro keyboard connected to a console port

2. 0SD

e via keyboard/mouse directly connected to the CPU board of the matrix
* via keyboard/mouse connected to a CON Unit and the OSD

3. External Switching Commands:

e via an external computer via Java tool (network connection required)

e via a media control (network or serial connection required)

5.1 Operation via Hotkeys

5.1.1 Direct Switching

The direct switching by hotkeys on a keyboard is the fastest way for a user to
switch at his console between different CPUs. He can switch video, keyboard and
mouse, or only video.

Direct Switching of Video, Keyboard, and Mouse

1. Start Command Mode with the hotkey. For control, the LEDs Shift and Scroll
flash at the keyboard, if Command Mode is activated.

2. Enter the index number of the new CPU from the list of favorites and confirm
with <Enter>. At the same time, the Command Mode is closed and the console
is connected to the new CPU with complete control.

NOTE: For best switching time, use identical mice, keyboards, and monitors.
This contributes to a smooth and delayless direct switching of the matrix.

Switching in Private Mode

1. Start Command Mode with the hotkey. The Shift and Scroll LEDs on the
keyboard flash at the keyboard when command mode is activated.

2. Enter the index number of the new CPU from the list of favorites and confirm
with <left Shift>, <Enter>. The Command Mode closes and the console
connects to the new CPU with complete control in Private Mode.
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Example: Switching to favorite CPU 3 in Private Mode
<left Shift>, <left Shift>, <3>, <left Shift>, <Enter>
Direct Switching of Video

1. Start Command Mode with the hotkey. For control, the LEDs Shift and Scroll
flashes at the keyboard, if command mode is activated.

2. Enter the index number of the new CPU from the list of favorites and confirm
with <Space>.

At the same time, the Command Mode is closed and the console is connected to
the new CPU with video only.

NOTE: You can only use the hotkeys to switch to unused and allowed CPUS.
Hotkeys are only supported if neither “Enable User Login” nor “Enable User
ACL" Is selected and the user is logged in the OSD.

Switch to previous CPU

1. Start Command Mode using hotkeys. For control, the Shift and Scroll LEDs on
the keyboard flash when Command Mode is activated.

2. Press the <p> key on your keyboard. The Command Mode closes, and the
console connects to the previous CPU with complete control.

NOTES:

If you switch to a previous CPU that was connected with Video Access before,
you will be connected to this CPU with full KVIM access.

You can only switch to unused and allowed CPUs with hotkeys. The “Force
Connect” and “Force Disconnect” options, as well as the restrictions of the User
ACL and CON ACL, are taken into account. Hotkeys are only supported if neither
Enable User Login nor the Enable User ACL is selected and the user is logged in
the OSD.

5.1.2 Scan Mode

The Scan Mode can show video signals of the different CPUs fast and without
delay and switch continuously using the hotkey. Switching between two video
signals can even take place within one frame.
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1. Start command mode with the hotkey. For control, the “Shift” and “Scroll”
LEDs flash at the keyboard if command mode is activated.

2. Press the “<Left Shift>" key and hold it down. You can now enter the index
numbers of the various CPUs from the list of favorites with the keyboard and
immediately switch to the video signal of the respective CPU after entering the
index number.

3. Leave Scan Mode by pressing “<Left Shift> + <Esc>.”

NOTE: For optimal results, use identical resolutions. This contributes to a smooth
and delay-free scan mode function.

5.1.3 Function Keys <F1>-<F12>

In Command Mode you can retrieve the Macros 1-12 with the function keys
<F1>-<F12> of the connected standard keyboard instead of the special macro
keyboard.

The deposited command sequence for the appropriate function key is executed
and Command Mode is left immediately.

NOTE: You don’t need to press the “Enter” key for confirmation of macros.
5.1.4 Addressing of Main and Sub Matrices

The ServSwitch DKM FX can be cascaded in two steps. You can optionally send
the commands (including opening the OSD) to the main or the sub matrix.

Whenever command mode is activated, you can select by a <m> or a <s>, if all
the following commands should be handled in the main or in the sub matrix.

OSD Access
e OSD access to the main matrix:
<Left Shift>, <Left Shift>, <m> (optional), <o>
* OSD access to the sub matrix:
<Left Shift>, <Left Shift>, <s>, <o>
Example: Switching to the CPU Port 23 of the slave matrix.

1. Switching to the CPU port (e.g. 12) of the main matrix that has the
connection to the sub matrix:

<Left Shift>, <Left Shift>, <m> (optional), <1>, <2>, <Enter>
2. Switching to the CPU Port 23 of the slave matrix:

<Left Shift>, <Left Shift>, <s>, <2>, <3>, <Enter>
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NOTE: The selected main/sub matrix mode is permanently activated until another
mode is manually activated. This means that if you select <s> for example,
all prospective commands will be sent to the sub matrix, but not if the
Command Mode is left in the meantime.

5.2 KVM Switching
To switch using the ServSwitch DKM FX, use OSD:

05D

Figure 5-1. OSD icon.
OSD
Select “Switch” in the main menu.
e ® [ ) m s

CPU Devices CON/CPU Data
1

01010 CPU_010123615
01009 CPU_010123955
01005 CPU_010124365
01006 _CPU_010124940
01001 CPU_ 910129195
01003 CPU_010129229 VIDED ONLY
01008 CPU_010129250

Figure 5-2. Menu Switch screen.
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The following information is shown in this menu:

Field

CON device
CON assigned
CPU connected
CON status
EXT list

CPU device
CPU assigned
CON connected
CPU status

EXT list

Table 5-1 Menu switch.
Description

Assigned physical extender unit (CON unit)

Virtual CON device that is assigned to the real CON device
Currently connected CPU device

Current connection status (CON device)

List of all available physical extender units (CON units)
Assigned physical extender unit (CPU unit)

Real CPU device that is assigned to a virtual CPU device
Currenlty connected CON device

Current connection status (CPU device)

List of all available extender units (CPU units)

To switch the console to any available CPU, follow these steps:

1. Select the CPU device you want to connect to the CON device from the “CPU

Devices"” list.

2. Confirm with the respective keyboard command according to the desired

connection type.

You can only switch the CON device to CPU devices that are available in the "CPU

Devices” list.
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Java Tool
Select “Switch > Switch Console to CPU” in the task area.
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Figure 5-3. Menu Switch—Switch Console to CPU.

All connected consoles and the associated CPU connections are shown in columns
in the working area in this menu.

NOTE: Switching operations can only be performed in on-line mode, that means
an active network connection between the matrix and the Java tool is
needed.

To set a KVM connection between a console and a CPU, double-click on the
corresponding selection box within the CPU column and select the requested CPU
(green).

To set a video connection between a console and a CPU, double-click on the
corresponding selection box within the CPU column and select the requested CPU
(orange).

NOTE: CPUs whose respective console does not have access rights will not appear
in the list.

You can use the following button to perform a switching operation:
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Table 5-2. Switching button.

Button  Function

Send Send effected switching operations to the matrix

NOTE: By activating the function Auto Send in the left lower corner of the
working area, switching operations will be done immediately without
confirmation by pressing the “Send” button.

Additionally, the menu offers the possibility to get from any console or CPU into
the associated configuration menu in the task area.

1. To get directly to Definition > CON Devices, use the right mouse button to click
on the respective console in the list and select “Open CON Device.”

2. To get directly to Definition > CPU Devices, use the right mouse button to click
on the respective console in the list and select “Open CPU Device.”

5.3 Extended Switching
You can perform switching operations via the OSD or Java icon.

/f,

‘N

osD [RNIAVS

)

Figure 5-4. OSD and Java icons.
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0OsD
To switch any console to any available CPU, proceed as follows:

Select “Extended Switch” in the main menu.

0 ot
83000 CON_|
0 Is
093083 CON_
03006 CON_

fSpien —— |
Figure 5-5. Menu Extended Switch.

1. Select the CON device from the “CON Devices” list that you want to switch to
a CPU device and open it by pressing “Enter”.

2. Select the CPU device from the “CPU Devices” list that you want to connect to
the open CON device.

3. Confirm with the respective keyboard command according to the desired
connection type.

Switching operations from the CON device can only be done to CPU devices that
are available in the “CPU Devices” list.
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The following information is shown in this menu:

Table 5-3. Extended switch menu fields.

Field Description

CON device The assigned physical extender unit.

CON assigned Virtual CON device that is assigned to the real CON device.

CPU connected  Currently connected CPU device.

CON status Current connection status (CON device).
EXT list List of all available physical extender units (CON units).
CPU device Assigned physical extender unit (CPU unit).

CPU assigned Real CPU device that is assigned to a virtual CPU device.

CON connected  Currently connected CON device.

CPU status Current connection status (CPU device).

EXT list List of all available physical extender units (CPU units).

You can select between the following switching functions:

Table 5-4. Switching functions.

Function Keyboard Command
Set a video-only connection. <Space>

Set a KVM connection. <Enter>

Set a KVM connection in private mode (video sharing disabled). <Shift> + <Enter>
Disconnect the CON device from the CPU device. <Backspace>
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Java Tool
You can switch using the Java Tool in two ways:
Possibility 1:

Select “Control > Extended Switch” in the task area.
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Figure 5-6. Menu Control — Extended Switch.

All connected consoles and the associated CPU connections are shown in columns
in the working area in this menu.

NOTE: Switching operations can only be performed in on-line mode, so you need
an active network connection between the matrix and the Java Tool.

To set a KVM connection between a console and a CPU, double-click on the
corresponding selection box in the “Full Access” column and select the requested
CPU.

To set a video connection between a console and a CPU, double-click on the
corresponding selection box in the “Video Only” column and select the requested
CPU.

To set a Private Mode connection between a console and a CPU, double-click on
the corresponding selection box within the “Private Mode” column and select the
requested CPU.
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NOTE: CPUs with respective consoles that do not have access rights will not
appear in the list.

The following symbols are shown in the connection overview:
Table 5-5. Connection overview fields.

Field Description
The CON device is connected via Shared Access with at least one further
console to the same CPU. The CON device has full access at the moment.

The CON device is connected via Shared Access with at least one further
console to the same CPU. The CON device has a video access connection
at the time.

You can use the following button to perform a switching operation:

Table 5-6. Swiching operation buttons.

Button Function

Send Send switching operations to the matrix.
Reset Disconnect all existing connections within the matrix.
Reload Reload switching status.

NOTES:

To perform switching operations immediately without confirmation, activate the
“Auto Send” function in the left lower corner of the working area. Switching
operations will be done immediately without confirmation when you press the
“Send” button.

By activating the “Hide Devices w/o Extender Assignment” function in the left
lower corner of the working area, only CON and CPU devices that are assigned to
an extender are shown.
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Possibility 2:

Select “Status > Matrix View" in the task area.
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Figure 5-7. Menu Status — Matrix View

To perform switching operations between CON and CPU devices, follow these
steps:

1. Move the mouse cursor to the port that has to be switched.

2. Hold down the left-mouse button and move the cursor to the port that has to
be connected to the initial port. The current cursor movement will be displayed
by a black auxiliary line.

3. Release the left-mouse button. A popup to select the available switching type
(Full Access, Video Access, or Private Mode) will be opened.

4. Select the desired switching type. The switching operation will be immediately
executed. At the same time, all extender units that are assigned to the involved
devices will be switched.

NOTE: If there is a red cross on a port when switching by using the Matrix View,
the console to be connected does not have access rights to the respective
CPU at this port.
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To disconnect an existing link between CON and CPU devices, follow these steps:
1. Click on the port that is to be disconnected by using the right mouse button.

2. Select the “Disconnect” function in the popup that appears. The connected
ports will be disconnected immediately. At the same time, all further
connections of the extenders assigned to the involved devices will be
disconnected.

5.4 USB 2.0 Switching

Switching USB 2.0 extenders works in a similar way as switching KVM extenders.

The following scenarios to switch USB 2.0 extenders are possible.

1. A extender unit with USB 2.0 will be created and assigned to an already
existing device with existing KVM extender units.

2. A separate device for the extender unit with USB 2.0 will be created without
assigning a KVM extender unit to that device. This possibility offers a separate
switching of the USB 2.0 signal.

NOTES:
Extended switching includes separate switching of USB 2.0 signals.

When switching USB 2.0 connections you should wait until the process of
registration of the USB 2.0 devices has been completed before you switch to the
next CPU (approximately 5—15 seconds). Otherwise the stability of the USB 2.0
connection can be affected negatively.

5.5 Presets

In this menu, you can create and activate predefined macros to switch the matrix
without loading a new configuration.

You can access the menu via the Java icon.

=7

Figure 5-8. Java icon.
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Select “Control > Presets” in the task area.
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Figure 5-9. Menu Control — Presets.

To create a new switch macro, proceed as follows:

1

. Open a new switch macro by pressing on the “New” symbol in the right

column of the working area. You'll be asked if the existing connections should
be taken over for the new switch macro.

. Set the desired switching operations in the corresponding columns (Full Access,

Video Only or Private Mode) by double-clicking on the respective selection box
or use the function for a disconnect (Disconnect CPU).

. Save the created switch macro by clicking the “Save” symbol in the right

column of the working area. A save dialog will be opened.

. Enter a name or the new switch macro and confirm by pressing the “OK"

button in the save dialog box.

. Click on a selected switch macro with the right mouse button to create a copy

of the current switch macro using the option “Save as....”

. You can delete already saved macros by pressing the “Delete” symbol.
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To load a predefined switching, proceed as follows:

1. Select the switch macro in the right column of the working area that has to be
loaded.

2. Activate the selected switch macro by pressing the “Send” button on the
bottom right of the working area.

NOTES:
A predefined switch macro can only be activated in on-line mode.

When loading presets, only the switching operations that are compliant with the
hardware and the configuration of the currently used matrix are taken into
account.

5.6 Serial Interface

RS5232

Figure 5-10. OSD icon.
The ServSwitch DKM FX enables you to switch via a serial interface (RS-232).

Detailed information for the serial interface and the corresponding switching

commands can be found in Chapter 6.

5.7 Power On and Power Down Functions

The ServSwitch DKM FX has the following power on and power down functions:

restart and reset.

5.7.1 Restart

To perform a restart, use OSD or Java.
-

=5

: —
0sD JAVA

Figure 5-11. OSD icon.
OsD

1. Select “Configuration > Restart Matrix” or “Restart IO Board” in the main
menu to restart either the matrix or the 1/0 boards.

2. To confirm the selection, press the “Yes” button. The matrix and the 1/0 boards
will be restarted with the current settings.
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5.7.2 Reset
Use the OSD to reset the extender:
m
)
0sD
Figure 5-12. OSD icon.

CAUTION: If you do a factory reset, all current settings and all configurations
stored in the matrix will be lost. This also applies to the network
parameters (reset to DHCP) and the admin password.

NOTE: If a firmware update has been done since the delivery, the matrix will be
set to the state defined there.

OsD

1. Select "Configuration > Reset Matrix” in the main menu.
2. To confirm the selection, press the “Yes” button.

The ServSwitch DKM FX will be reset to the factory settings.

5.7.3 Power Down

Slide the on and off switch at the main sockets of the power supply units to start
or switch off the matrix.
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6. Serial Control

Use the following parameters to control the ServSwitch DKM FX via its serial
interface.

115.2K, 8, 1, NO

(115.2 kbps, 8 data bits, 1 stop bit, no parity)

Command

<STX>, <command byte (CMD)>, [data bytes (DO...DN)], <ETX>
[ ] = Optional elements

Response

<ACK> , [<ECHO>]

[ 1= Optional elements

<ECHO> reports the ServSwitch DKM FX sequences enabled by a command that
shows the new switching status of the ServSwitch DKM FX. The echo can be
used to update user applications and to operate several matrices in parallel.

Parameter Description

Command byte: In the range 0x40 to Ox6F (see the list of allowed commands
below).

Data bytes: a) To prevent transferring control statements of control commands
while transferring binary data, the data are divided into low-nibble and high-
nibble. The data are distributed to the low nibbles of two bytes and provided
with an offset by 0x60, for example, Ox1F.

=> 0x61 + Ox6F

b) 7-bit data: (0x0 to Ox7F) are provided with an offset by 0x80,
e.g. 0000011 => 0x83

) ASCII data => 0x20 to Ox7E are transmitted unencrypted.
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Special characters:

ACK
NAK
STX
ETX
CR
ESC
HTAB
LF

0x06
0x15
0x02
0x03
0x0D
Ox1B
0x09
Ox0A

Sequence of a Data Communication

Table 6-1. Data communication sequence.

ServSwitch KVM DKM FX

Control CPU

1. Send a command

2. Acquire a command, process a

command, block further commands.

3. a) Errors occurred: <NAK>

b) No errors: <ACK><ECHO>

¢) Optional: Reply telegram with data

4. a) Repeat telegram
b) Next command
) Receive and process the repeat telegram

NOTE: The serial interface can be blocked while OSD is open.

Switching Functions Telegrams

Table 6-2. Input port's request for output port.

Bytes  Description Coding

1 Control character 0x1B

1 Server indentification 0x5B

1 Command 0x42

2 Total length of telegram (7 bytes, binary) 0x07 0x00

2 Requested output port (binary, 1...max. ports) 0x01 0x00 (for port 1) to 0x120 0x00 (for port

288)
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Example:
Input port’s request for output Port 160
0x1B 0x5B 0x42 0x07 0x00 O0xA0 0x00

Table 6-3. Return of input port for output port.

Bytes  Description Coding

1 Control character 0x1B

1 Server indentification 0x5B

1 Command 0x42

2 Requested output port (binary, 1...max. ports)  0x01 0x00 (for Port 1) to 0x120 0x00 (for Port 288)

2 Assigned input port (binary, 1...max. ports) 0x01 0x00 (for Port 1) to 0x120 0x00 (for Port 288)
Example:

Input Port 17's return for output Port 160
0x1B 0x5B 0x42 0x09 0x00 0xAO0 0x00 0x11x00

Table 6-4. Connection of input port with output port.

Bytes  Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x43

2 Total length of telegram (9 bytes, binary) 0x09 0x00

2 Requested output port (binary, 1...max. ports)  0x01 0x00 (for Port 1) to 0x120 0x00 (for Port 288)

2 Assigned input port (binary, 1...max. ports) 0x01 0x00 (for Port 1) to 0x120 0x00 (for Port 288)
Example:

Connection of input Port 17 with output Port 160
0x1B 0x5B 0x43 0x09 0x00 0xAO0 0x00 0x11 0x00

724-746-5500 | blackbox.com Page 163



Chapter 6: Serial Control

Table 6-5. Request of input port for output port with a fixed total port number.

Bytes  Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x44

2 Total length of telegram (9 bytes, binary) 0x09 0x00

2 ;‘g::)’er Ui IS () Tl 0x01 0x00 (for Port 1) to 0x120 0x00 (for Port 287)

2 Requested output port (binary, 1...max. ports)  0x01 0x00 (for Port 1) to 0x120 0x00 (for Port 288)
Example:

Request of input port for output Port 25 with a total port number of 160
0x1B Ox5B 0x44 0x09 0x00 0xAO0 0x00 0x19 0x00

Table 6-6. Return of input port for output port with a fixed port number.

Bytes  Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x44

2 Total length of telegram (7 bytes, binary) 0x07 0x00

5 Number of output ports (binary, 1...max. 288  0x01 0x00 (for Port 1) to 0x120 0x00 (for 287
ports) ports)

Example:

Return of input Port 17 for output Port 25 with a total port number of 160.
0x1B 0x5D 0x44 0x09 0x00 0xAO0 0x00 0x19 0x00 0x11 0x00
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Table 6-7. Connection of input port with output port
with a fixed total port number.

Bytes  Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x45

2 Total length of telegram (7 bytes, binary) 0x07 0x00

) Number of output ports (binary, 1...max. 0x01 0x00 (for Port 1) to 0x120 0x00 (for 287
2887ports) ports)

Example:

Connection of input Port 17 with output Port 25 with a total port number of 160

0x1B 0x5B 0x45 0x07 0x00 OxAO 0x00 0x19 0x00 0x11 0x00

Table 6-8. Request of switching matrix.

Bytes  Description Coding
1 Control character 0x1B
1 Server identification 0x5B
1 Command 0x46

Table 6-9. Return of the switching matrix (input port for all output ports).

Bytes  Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x46

2 Total length of telegram (7 bytes, binary) 0x07 0x00

5 Input port whose signal is sent to output port ~ 0x01 0x00 (for Port 1) to 0x120 0x00 (for 288

QutPort (n)

ports)
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Example:
Return input Port 17 for all output ports
O0x1B 0x5D 0x46 0x07 0x00 0x11 0x00

Table 6-10. Request of CPU (input) for CON (output).

Bytes  Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x46

2 Total length of telegram (7 bytes, binary) 0x07 0x00

0x01 0x00 (for Console 1) to 0x11F 0x00

2 Requested output console (for Console 287)

Example:
Request of CPU (input) for Console 23
0x1B 0x5B 0x47 0x07 0x00 0x17 0x00
Table 6-11. Return of CPU (input) for CON (output).

Bytes  Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x47

2 Total length of telegram (9 bytes, binary) 0x09 0x00

) seuEs e ek el 0x01 0x00 (for Console 1) to 0x11F 0x00 (Console
287)

2 Requested input CPU 0x01 0x00 (for CPU 1) to 0x11F 0x00 (for CPU 287)
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Example:
Return of CPU 34 for Console 23
0x1B 0x5D 0x47 0x09 0x00 0x17 0x00 0x22 0x00

Table 6-12. Connection of CPU (input) with CON (output).

Bytes  Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x48

2 Total length of telegram (9 bytes, binary) 0x09 0x00

) Hosuasiad gosals 0x01 0x00 (for Console 1) to 0x11F 0x00 (for

Console 287)

7 Requested CPU 22%1 208><7O>O (for CPU 1) to 0x11F 0x00 (for

Example:

Connection of CPU 43 with Console 23
0x1B 0x5B 0x48 0x09 0x00 0x17 0x00 0x2B 0x00

Table 6-13. Request of CPU (input) for CON (output)
with a fixed console number.

Bytes  Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x49

2 Total length of telegram (9 bytes, binary) 0x09 0x00

3 Total number of consoles (binary, 1...max. 0x01 0x00 (for Console 1) to 0x11F 0x00 (for
CONs) 287 Consoles)

0x01 0x00 (for Console 1) to 0x11F 0x00 (for

2 Requested consoles Console 287)
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Example:
Request of CPU (input) for Console 23 with 50 consoles in total
0x1B 0x5B 0x49 0x09 0x00 0x32 0x00 0x17 0x00

Table 6-14. Return of CPU (input) for CON (output)
with a fixed console number.

Bytes  Description Coding
1 Control character 0x1B
1 Server identification 0x5D
1 Command 0x49
2 Total length of telegram (7 bytes, binary) 0x07 0x00
3 Total number of consoles (binary, 1...max. 0x01 0x00 (for console 1) to 0x11F 0x00 (for
CONs) 287 consoles)
Example:

Return of CPU 43 for Console 23 with 50 consoles in total
0x1B Ox5D 0x49 0x07 0x00 0x32 0x00 0x17 0x00 0x2B 0x00

Table 6-15. Connection of CPU (input) for CON (output)
with a fixed console number.

Bytes  Description Coding
1 Control character 0x1B
1 Server identification 0x58B
1 Command 0x50
2 Total length of telegram (7 bytes, binary) 0x07 0x00
3 Total number of consoles (binary, 1...max. 0x01 0x00 (for Console 1) to 0x11F 0x00 (for
CONs) 287 consoles)
Example:

Connection of 43 with Console 23 with 50 consoles total

0x1B -x5B 0x50 0x07 0x00 0x32 0x00 0x17 0x00 0x2B 0x00
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Table 6-16. Request of CON (input) for CPU (output).

Bytes  Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x51

2 Total length of telegram (7 bytes, binary) 0x07 0x00

3 Total number of consoles (binary, 1...max. 0x01 0x00 (for CPU 1) to 0x11F 0x00 (for CPU
CONs) 287)

Example:

Request of CON (input) for CPU 23
0x1B 0x5B 0x51 0x07 0x00 0x17 0x00

Table 6-17. Return of CON (input) for CPU (output).

Bytes  Description Coding

1 Control character 0x1B

1 Server identification 0x5D

1 Command 0x51

2 Total length of telegram (9 bytes, binary) 0x09 0x00

2 Requested output CPU 0x01 0x00 (for CPU 1) to 0x11F 0x00 (for CPU 287)
7 Requested input console 0x01 0x00 (for Console 1) to 0x11F 0x00 (for

console 287)
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Example:
Request of Console 23 for CPU 23
0x1B 0x5D 0x09 0x00 0x2B 0x00 0x17 0x00
Table 6-18. Connection of CON (input) with CPU (output).

Bytes  Description Coding
1 Control character 0x1B
1 Server identification 0x5B
1 Command 0x52
2 Total length of telegram (9 bytes, binary) 0x09 0x00
2 Requested output CPU 0x01 0x00 (for CPU 1) to 0x11F 0x00 (for CPU 287)
. 0x01 0x00 (for Console 1) to 0x11F 0x00 (for
2 Requested input console Console 287)
Example:

Connection of Console 23 with CPU 43

0x1B Ox5B 0x52 0x09 0x00 0x2B 0x00 0x17 0x00

Table 6-19. Request CON (input) for CPU (output) with a fixed CPU number.

Bytes  Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x52

2 Total length of telegram (9 bytes, binary) 0x09 0x00

2 Total number of CPUs 0x01 0x00 (for CPU 1) to 0x11F 0x00 (for 159 CPUs)
) Requested output for CPU (binary, 1...max. 0x01 0x00 (for Console 1) to 0x11F 0x00 (for

CPUs)

Console 287)
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Example:

Request for CPU 43 with 50 CPUs in total
O0x1B 0x5B 0x53 0x09 0x00 0x32 0x00 0x2B 0x00
Table 6-20. Return of CON (Input) for CPU (Output) with a fixed CPU number.

Bytes  Description Coding

1 Control character 0x1B

1 Server identification 0x5D

1 Command 0x53

2 Total length of telegram (7 bytes, binary) 0x07 0x00

2 Total number of CPUs 0x01 0x00 (for 1 CPU) to 0x11F 0x00 (for 287 CPUs)
Example:

Return of Console 23 for CPU 43 with 50 CPUs in total
0x1B 0x5D 0x53 0x07 0x00 0x32 0x00 0x2B 0x00 0x17 0x00

Table 6-21. Connection of CON (input) with CPU (output)
with a fixed total CPU number.

Bytes  Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x54

2 Total length of telegram (7 bytes, binary) 0x07 0x00

2 Total number of CPUs 0x01 0x00 (for 1 CPU) to 0x11F 0x00 (for 287 CPUs)
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Example:
Connection of Console 23 with CPU 43 with 50 CPUs in total
0x1B 0x5B 0x54 0x07 0x00 0x32 0x00 0x2B 0x00 0x17 0x00

Table 6-22. Connection of CON (input) with CPU (output)
and CPU (input) with CON (output).

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x55

2 (Tgtsy' t'gsnlgg:;;’:y;e'egram 0x09 0x00

2 Requested CPU 0x01 0x00 (for 1 CPU) to 0x11F 0x00 (for 287 CPUs)

2 Requested console 0x01 0x00 (for Console 1to 0x11F 0x00 (for Console 287)

Example:
Connection of Console 23 (input) with CPU 43 (output)
0x1B 0x5B 0x55 0x09 0x00 0x2B 0x00 0x17 0x00

Table 6-23. Connection of CON (input) with CPU (output)
and CPU (input) with CON (output) with a fixed CPU number.

Bytes  Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x56

2 Total length of telegram (7 bytes, binary) 0x07 0x00

2 Total number of CPUs 0x01 0x00 (for 1 CPU) to 0x11F 0x00 (for 287 CPUs)
Example:

Connection of Console 23 with CPU 43 and Console 24 with CPU 44 with 50
existing CPUs

0x1B 0x5B 0x56 0x07 0x00 0x32 0x00 0x2B 0x00 0x17 0x00 0x2C 0x00
0x18 0x00
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7. Troubleshooting

Tables 7-1 through 7-7 in Sections 7.1 through 7.7 provide support for problems
with the ServSwitch DKM FX matrix. This help assumes a functional extender
route. Before running, make sure your extenders’ matrixes work over a peer-to-
peer connection. This can be supported by the use of a CATx or fiber coupler.

7.1 External Failure

Table 7-1. External failure.

Problem Possible Cause Solution

ServSwitch DKM FX cannot be started Fuse at the standard appliance outlet is out ~ Check fuse

7.2 Video Interference
Table 7-2. Video interference.

Problem Possible Cause Solution

Opening the OSD is not possible  No OSD jumper set Set Jumper 11 on the CON unit

Check the connection, length,
Incorrect video display Cable connection disturbed  and quality of the interconnection
cable to the units

7.3 Fans Malfunction

Table 7-3. Fans malfunction.

Problem Possible Cause Solution

Communication to fan

Fans only run under full load e

Remove and reinstall the fan tray

Contact Black Box Technical Support at

Fans do not run; LED OK ison  Fans are defective 724-746-5500 or info@blackbox.com

724-746-5500 | blackbox.com Page 173



Chapter 7: Troubleshooting

7.4 Power Supply Units Malfunction

Table 7-4. Power supply units malfunction.

Problem

Possible Cause

Solution

Power supply units not locked
correctly

Check the power supply unit’s lock and
plug-in

ServSwitch DKM FX
cannot be started

No power supply is available

Check that cables for the power supply
are connected correctly

Power supply units are not
switched on

Check the slide to switch on the power
supply units

7.5 Network Error

Table 7-5. Network error.

Problem

Possible Cause

Solution

Network settings are not resumed after

editing

yet completed

ServSwitch DKM FX restart is not

Restart the unit

7.6 ServSwitch DKM FX Failure

Table 7-6. ServSwitch DKM FX failure.

Problem

Possible Cause

Solution

Serial control is impossible
or restricted

CPU and ServSwitch DKM FX
are running at a different baud
rate

Adapt the baud rate in the
ServSwitch DKM FX and in the
CPU

Serial control via the RJ-45
port is not possible

Wrong network cable

Use a cross-pinned network cable

Port definitions as USB 2.0
invalid

ServSwitch DKM FX restart not
yet completed

Restart the ServSwitch DKM FX
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7.7 Blank Screen

Problem

Monitor remains dark after

switching operation

LED 1 on or LED 2 off

LED 3 off

Figure 7-1. LEDs on the ServSwitch DKM FX.

Table 7-7. LED indications.

Possible Cause

Switching to a CPU port
without active source
(computer, CPU)

Connection of a console
with a CON port or
connection of a CPU to a
CPU port not established
correctly

Connections of the CON

unit, ServSwitch DKM FX,
and the CPU unit

Power supply

7.8 Contacting Black Box
If you determine that your ServSwitch DKM FX is malfunctioning, do not attempt

to alter or repair the unit. It contains no user-serviceable parts. Contact Black Box
Technical Support at 724-746-5500 or info@blackbox.com.

Solution

Connect the computer or CPU

Check CON and CPU port connections at the
ServSwitch DKM FX

Check the cables and connectors (no cable,
cable break, CPU/CON unit off-line, CPU/CON
unit connected to the wrong port

Check the power supply units and connection
to the power network

Before you do, make a record of the history of the problem. We will be able to
provide more efficient and accurate assistance if you have a complete description,

including:
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e the nature and duration of the problem.
e when the problem occurs.
e the components involved in the problem.

e any particular application that, when used, appears to create the problem or
make it worse.

7.9 Shipping and Packaging
If you need to transport or ship your ServSwitch DKM FX:

e Package it carefully. We recommend that you use the original container.

e If you are returning the unit, make sure you include everything you received
with it. Before you ship for return or repair, contact Black Box to get a Return
Authorization (RA) number.
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Appendix. Glossary

The following terms are commonly used in this guide or in video and KVM
technology:

AES/EBU — Digital audio standard officially known as AES3, used for carrying
digital audio signals between devices.

CATx — Any CAT5e (CAT6, CAT7) cable.

CGA — The Color Graphics Adapter (CGA) is an old analog graphics standard
with up to 16 displayable colors and a maximum resolution of 640 x 400 pixels.

Component Video — The Component Video (YPbPr) is a high-quality video
standard that consists of three independently and separately transmittable video
signals, the luminance signal, and two color difference signals.

Composite Video — The Composite Video is also called FBAS and it is part of
the PAL TV standard.

CON Unit — Component of a ServSwitch DKM FX or media extender that
connects to the console (monitor(s], keyboard and mouse; optionally also with
USB 2.0 devices).

CPU Unit — Component of a ServSwitch DKM FX or media extender that
connects to a source (computer, CPU).

DDC — The Display Data Channel (DDC) is a serial communication interface
between a monitor and a source (computer, CPU). It enables data exchange via
monitor cable and automatic installation and configuration of a monitor driver
by the operating system.

Dual Access — A system that operates a source (computer, CPU) from two
consoles.

Dual-Head — A system with two video connections.

Dual Link — A DVI-D interface for resolutions up to 2560 x 2048 by signal
transmission of up to 330 MPixel/s (24-bit).

DVI — Digital video standard, introduced by the Digital Display Working Group
(http://www.ddwg.org). See also Single Link and Dual Link. The signals have
TMDS level.

DVI-I — A combined signal (digital and analog) that allows running a VGA
monitor at a DVI-I port—in contrast to DVI-D (see DVI).
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Fiber — Single-mode or multimode fiber cables.

EGA — The Enhanced Graphics Adapter (EGA) is an old analog graphics
standard, introduced by IBM® in 1984. It uses a DB9 connector.

FBAS — The analog color video baseband signal (FBAS) is also called Composite
Video and it is part of the PAL TV standard.

Console — Keyboard, mouse, and monitor.
KVM — Keyboard, video, and mouse.

Mini-XLR — Industrial standard for electrical plug connections (3-pole) for the
transmission of digital audio and control signals.

Multimode — 62.5-y or 50-p fiber cable.

OSD — An OSD (on-screen display) is used to display information or to operate a
device.

Quad-Head — A system with four video connections.

RCA (Cinch) — A non-standardized plug connection that transmits electrical
audio and video signals, especially with coaxial cables.

SFP — SFPs (Small Form Factor Pluggables) are pluggable interface modules for
Gigabit connections. SFP modules are available for CATx and fiber interconnect
cables.

S/PDIF — A digital audio interconnect used in consumer audio equipment over
relatively short distances.

Single-Head — A system with one video connection.

Single Link — A DVI-D interface for resolutions up to 1920 x 1200 by signal
transmission of up to 165 MPixel/s (24-bit). Alternative frequencies are Full HD
(1080p), 2K HD (2048 x 1080), and 2048 x 1152.

Single-Mode — 9y fiber cable.

S-Video (Y/C) — The S-Video (Y/C) is a video format that transmits luminance
and chrominance signals separately. It has a higher-quality standard than FBAS.

TOSLINK® — Standardized fiber connection system for digital transmission of
audio signals (FO5 plug connection).

Triple-Head — A system with three video connections.
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USB HID — USB HID devices (human interface devices) allow for data input. You
don’t need a special driver during installation; “New USB-HID device found” is
reported. Typical HID devices include keyboards, mice, graphics tablets, and
touchscreens. Storage, video, and audio devices are not HID.

VGA — Video Graphics Array (VGA) is a computer graphics standard with a
typical resolution of 640 x 480 pixels and up to 262,144 colors. Its is preceded by
the graphics standards MDA, CGA and EGA.

A.1 Matrix-Specific Glossary
Auto Disconnect — Matrix function that allows an automatic disconnect
between a console and a CPU, if the OSD is opened via this console.

Auto Logout — Matrix function that describes the duration of inactivity after the
user has been logged out from the OSD at this console.

CON Device — Logical term that summarizes several physical extenders to switch
more complex console systems via matrix.

CON Timeout — Matrix function that allows an automatic disconnect of the
console from the connected CPU after a predefined time.

Console ACL — Console ACL (Access Control List) is a list that shows the respec
tive switching rights for the various consoles.

CPU Auto Connect — Matrix function that allows an automatic connection
establishment between the own console and a random available CPU.

CPU Device — Logical term that summarizes several physical extenders to switch
more complex CPU systems via matrix.

CPU Timeout — Matrix function that allows the user to disconnect after a
predefined period of time of inactivity from the respective CPU.

EXT Unit — Part or extender board of a CON or CPU unit with a connection to
the matrix. A CON or CPU unit can consist of several EXT devices.

Force Connect — Matrix function that allows a user to switch with his own
console to a CPU that is already used. This enables the user to take keyboard and
mouse control. The connected console loses K/M control but keeps video.

Force Disconnect — Matrix function that allows to switch with the console to a
CPU that is already used. This enables the user to take KVM control. The
connected console loses complete KVM control.

Java Tool — Java based control and configuration tool for the ServSwitch DKM
FX matrix.
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Keyboard Connect — Matrix function that allows taking over the keyboard
control of an inactive console.

Macro Keys — Programmable keys that string together commands to the matrix.

Mouse Connect — Matrix function that enables a user to control an inactive
console’s mouse.

Non-Blocking-Access — Matrix configuration in which no user can be disturbed
by an activity of another user.

OSD Timeout — Matrix function that closes the OSD automatically after a
predefined period of time of inactivity.

Release Time — Matrix function that enables a console connected to the same
CPU to release the K/M control after a predefined time.

Tie-Line — Communication connection to and between extension modules in a
network environment.

User ACL — User ACL (Access Control List) is a list that shows the respective
switching rights for the various users.

Video Sharing — Matrix function that enables switching from a user’s own
console to any CPU with video.
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